Ask Your Question
2

Why am I getting "python:any (>= 2.7.1-0ubuntu2) but it is not installable" on Raspian Wheezy?

asked 2014-12-08 09:51:42 -0500

arnoldbail gravatar image

I installed Indigo on Raspian Wheezy on the Raspberry Pi using the excellent article http://wiki.ros.org/ROSberryPi/Instal...

The ROS system functions well; but, when I try to install

$ sudo apt-get update $ sudo apt-get install tightvncserver or $ sudo apt-get install vsftpd

I get the following errors

Reading package lists... Done Building dependency tree
Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: python-catkin-pkg : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable python-rosdep : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable python-rosdistro : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable python-rospkg : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I’m a relative NOOB to Linux. Is there any guidance?

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
0

answered 2014-12-09 08:26:10 -0500

arnoldbail gravatar image

I found the work-around/bypass in raspberry pi with ROS Indigo ( or any new Release of ROS)

I edited /var/lib/dpkg/status deleting the python:any segments.

edit flag offensive delete link more

Comments

I keep bumping my head on this, but can't find "python:any" in the mentioned file... Tried a few variants, but nothing seems to pop up. Thoughts?

emccarron72 gravatar image emccarron72  ( 2014-12-17 10:13:23 -0500 )edit

Same problem, I cannot find it too

Alvar gravatar image Alvar  ( 2014-12-21 17:10:09 -0500 )edit

Similar problem. Since it seems that the unmet dependency is the one about python ( Depends: python:any (>= 2.7.1-0ubuntu2) ) I tried checking my version with

python -V

But it responds: Python 2.7.3. So it's higher that 2.7.1. Could it be something about the "-0ubuntu2" part?

Sergio MP gravatar image Sergio MP  ( 2015-02-02 04:46:23 -0500 )edit

I have the same problem. Any workaround??

kevin.kuei.0321@gmail.com gravatar image kevin.kuei.0321@gmail.com  ( 2015-05-21 05:03:20 -0500 )edit

Me too, anyone figure it out?

TomJacobs gravatar image TomJacobs  ( 2015-06-02 02:10:27 -0500 )edit

This is big issue omho. I seem to be unable to use catkin_make because of this! And yes, I can't find anything like that indicated in the answer.

rbaleksandar gravatar image rbaleksandar  ( 2015-08-23 21:03:32 -0500 )edit
1

answered 2015-07-30 10:32:50 -0500

SebastianStigler gravatar image

The answer to this problem is quite simple (ok, it took me two days until I read the complete article http://wiki.ros.org/ROSberryPi/Instal... and found the correct hint):

Just befor section "2.3 Building the catkin Workspace" is a box with the following note:

Note: Rosdep may report that python-rosdep, python-catkin-pkg, python-rospkg, and python-rosdistro failed to install; however, you can ignore this error because they have already been installed with pip.

edit flag offensive delete link more

Comments

It tells you to ignore Failed to detect successful installation of ... and not to ignone unmet dependencies and broken packages facepalm

rbaleksandar gravatar image rbaleksandar  ( 2015-08-23 21:05:02 -0500 )edit
0

answered 2015-06-02 02:11:34 -0500

TomJacobs gravatar image

Me too, and I have no ':any' in that file, what's the fix is it to reinstall python?

edit flag offensive delete link more
0

answered 2015-08-24 23:43:13 -0500

bgewehr gravatar image

updated 2015-08-25 00:04:26 -0500

On a brand new Raspian Wheezy I geht this:

The following packages have unmet dependencies:
python-rosdep : Depends: python:any (>= 2.7.1-0ubuntu2) but it is not installable
             Depends: python-catkin-pkg but it is not going to be installed
             Depends: python-rospkg (>= 1.0.34) but it is not going to be installed
             Depends: python-rosdistro (>= 0.4.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
ERROR: the following rosdeps failed to install
apt: command [sudo -H apt-get install -y python-rospkg] failed
apt: command [sudo -H apt-get install -y python-catkin-pkg] failed
apt: command [sudo -H apt-get install -y python-rosdep] failed
apt: Failed to detect successful installation of [python-rospkg]
apt: Failed to detect successful installation of [python-catkin-pkg]
apt: Failed to detect successful installation of [python-

The unmet dependencies can't be ignored, right?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-12-08 09:51:42 -0500

Seen: 7,846 times

Last updated: Aug 25 '15