Ask Your Question
0

Plugin Not Registered Error (SBPLLatticePlanner)

asked 2014-11-28 01:46:44 -0600

ROSCMBOT gravatar image

updated 2014-11-29 17:05:30 -0600

Hello,

I managed to compile sbpl_lattice_planner under hydro. Its plugin is registered and when running

rospack plugins --attrib=plugin nav_core

outputs

sbpl_lattice_planner /home/yan/straight_nav/src/navigation_experimental/sbpl_lattice_planner/bgp_plugin.xml

However, when I'm running the navigation, I get the following error, showing the plugin is not registered:

[ INFO] [1417160047.298448917]: Loading from pre-hydro parameter style
[ INFO] [1417160047.349348370]: Using plugin "static_layer"
[ INFO] [1417160047.435368190]: Requesting the map...
[ INFO] [1417160047.667259434]: Resizing costmap to 4000 X 4000 at 0.050000 m/pix
[ INFO] [1417160047.782624823]: Received a 4000 X 4000 map at 0.050000 m/pix
[ INFO] [1417160047.788759929]: Using plugin "obstacle_layer"
[ INFO] [1417160047.819685654]:     Subscribed to Topics: 
[ INFO] [1417160047.935887527]: Using plugin "inflation_layer"
[FATAL] [1417160048.000805977]: Failed to create the SBPLLatticePlanner planner, are you sure it is properly registered and that the containing library is built? Exception: According to the loaded plugin descriptions the class SBPLLatticePlanner with base class type nav_core::BaseGlobalPlanner does not exist. Declared types are  carrot_planner/CarrotPlanner navfn/NavfnROS
[move_base-6] process has died [pid 20298, exit code 1, cmd /opt/ros/hydro/lib/move_base/move_base odom:=shark/odom __name:=move_base __log:=/home/yan/.ros/log/e734a656-76d0-11e4-95d8-0024e832832e/move_base-6.log].
log file: /home/yan/.ros/log/e734a656-76d0-11e4-95d8-0024e832832e/move_base-6*.log

Any thoughts?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-11-28 08:28:55 -0600

ahendrix gravatar image

This works for me on Hydro. Are you sure you've sourced the setup.bash for the workspace containing sbpl_lattice_planner before you launch move_base?

edit flag offensive delete link more

Comments

I guess the OP solved this, because he followed up with a question indicating that SBPL is working: http://answers.ros.org/question/19858...

ahendrix gravatar imageahendrix ( 2014-11-30 22:00:14 -0600 )edit

Yes, Thanks @ahendrix . I marked your comment as the correct response.

ROSCMBOT gravatar imageROSCMBOT ( 2014-11-30 22:20:33 -0600 )edit
1

answered 2014-11-30 00:07:34 -0600

fergs gravatar image

You might need to run "rospack profile" to force a recheck of all package.xmls and find the plugin.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-28 01:46:44 -0600

Seen: 575 times

Last updated: Nov 30 '14