Ask Your Question
0

How to install and run openni_tracker for Hydro

asked 2014-11-27 17:50:44 -0600

updated 2014-11-30 17:23:51 -0600

Thank you in advance for your help and patience. I am new to ROS and could use some help with openni_tracker and the Microsoft Kinect. I'm am using Ubuntu 12.04 and ROS Hydro

I have installed openni_camera and openni_launch according to openni_camera:

$ sudo apt-get install ros-hydro-openni-camera
$ sudo apt-get install ros-hydro-openni-launch
$ rosdep update

I have no problems running openni_launch and viewing the point cloud data, color image, or disparity view using Rviz and image_view.

I have installed openni_tracker:

$ sudo apt-get install ros-hydro-openni-tracker
$ rosdep update
$ roslaunch openni_launch openni.launch
$ rosrun openni_tracker openni_tracker

and get an error

[ERROR] [1416949546.535139208]: Find user generator failed: This operation is invalid!

I've uninstalled ROS (both Groovy and Hydro) with

$ sudo apt-get remove ros-<distro>

and still the problem comes up. I've read in a few threads that I should install NITE dev or something to help. But have also noticed that it hasn't helped some people.

Again, I am new to this, so some step-by-step help would be much appreciated. Thanks in advance.

UPDATE: I've also installed openni2_tracker...located in ~/catkin_ws/src/. When I go back to my catkin_ws and use catkin_make, I get the following errors:

-- ==> add_subdirectory(openni2_tracker)
CMake Error at /opt/ros/hydro/share/catkin/cmake/catkinConfig.cmake:75 (find_package):
  Could not find a configuration file for package orocos_kdl.

  Set orocos_kdl_DIR to the directory containing a CMake configuration file
  for orocos_kdl.  The file will have one of the following names:

    orocos_kdlConfig.cmake
    orocos_kdl-config.cmake

Call Stack (most recent call first):
  openni2_tracker/CMakeLists.txt:3 (find_package)


-- Using these message generators: gencpp;genlisp;genpy
-- /usr/lib/libOpenNI2.so
status
status
CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
Nite2_INCLUDEDIR
   used as include directory in directory /home/ecejames01/catkin_ws/src/openni2_tracker
Nite2_LIBRARY
    linked by target "openni2_tracker" in directory /home/ecejames01/catkin_ws/src/openni2_tracker

-- Configuring incomplete, errors occurred!
make: *** [cmake_check_build_system] Error 1
Invoking "make cmake_check_build_system" failed

I am not sure what this means or how to fix the problem...thanks for your help.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-11-30 19:26:28 -0600

updated 2014-11-30 19:31:50 -0600

I have found the solution to my issue on this page and this page.

And was able to successfully view the tf for all my 'joints' via Rviz using this page.

Thanks.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-27 17:50:44 -0600

Seen: 1,388 times

Last updated: Nov 30 '14