ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

openni2_launch doesn't work with carmine 1.09 connected to USB3.0

asked 2014-11-12 20:44:38 -0500

moyashi gravatar image

Hi there,

I have a trouble that openni2_launch doesn't work.
I'm using carmine 1.09 connected to USB3.0, because my MacBookPro doesn't have any USB2.0 ports.

I've already carried out firmware update for carmine 1.09, however it still doesn't work and I have the following errors.
Actually, the errors are the same as the errors which I had before I update carmine's firmware.

[ INFO] [1415845653.463960586]: Device "1d27/0609@1/12" with serial number "" connected
[ INFO] [1415845653.468566285]: No matching device found.... waiting for devices. Reason: openni2_wrapper::OpenNI2Device::OpenNI2Device(const string&) @ /tmp/buildd/ros-indigo-openni2-camera-0.2.2-0trusty-20141015-0837/src/openni2_device.cpp @ 74 : Initialize failed
Could not open "1d27/0609@1/12": Failed to open the USB device!

How can I solve this problem ?

  • OS : Ubuntu 14.04
  • ROS : Indigo
  • Hardware : MacBookPro (which has 2 USB3.0 ports)
edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2014-11-13 03:21:41 -0500

fergs gravatar image

Looks like you now have a device ID of 1d27:0609. Unfortunately, the 0609 is not in the default udev rules that get installed with the libopenni2 debian in ROS. Check your /lib/udev/rules.d/40-libopenni2-0.rules file and see if it contains a line with product ID 0609. It probably won't, so add the following to a file in /etc/udev/rules.d (such as /etc/udev/rules.d/40-libopenni2-0.rules):

SUBSYSTEM=="usb", ATTR{idProduct}=="0609", ATTR{idVendor}=="1d27", MODE:="0666", OWNER:="root", GROUP:="video"

(don't modify the /lib/udev version, as it will get overwritten the next time you update debs)

Unfortunately, even with updated firmware and proper udev rules, these devices can be unreliable on USB3. One thing that I have found to work (sometimes) is to blacklist the "usb_snd_audio" kernel module, as this is used for the microphones on the sensor, and it appears the sensor audio hardware is quite unreliable. The other thing to check is that you actually have a valid udev rule.

edit flag offensive delete link more


Thank you !! I could solved the problem thanks to you !! Now carmine 1.09 works well with Ubuntu 14.04, ROS Indigo and the latest MacBookPro's USB 3.0. Strangely, when I connect it to USB port on right side, it doesn't work. However it doesn't matter. Thank you !

moyashi gravatar image moyashi  ( 2014-11-17 01:56:42 -0500 )edit

This does not work on Ubuntu 12.04, ROS Hydro ... (Carmine has the Firmware update)

atp gravatar image atp  ( 2014-11-25 15:26:51 -0500 )edit

I have the same problem on ubuntu 12.04, hydro.

ryohei gravatar image ryohei  ( 2014-11-25 23:37:46 -0500 )edit

12.04 version of libopenni2 is too old for the upgraded firmware.

fergs gravatar image fergs  ( 2014-11-26 12:11:21 -0500 )edit

I see. Is it possible to use drivers compiled from source?

atp gravatar image atp  ( 2014-11-26 15:17:56 -0500 )edit

You could build a new libopenni2 deb using git-buildpackage and install it, and then build openni2_camera from source. The repository for libopenni2 as packaged for ROS indigo is here:

fergs gravatar image fergs  ( 2014-11-27 04:52:35 -0500 )edit

Thanks, fergs. Did this a while ago and forgot this important step.

bit-pirate gravatar image bit-pirate  ( 2015-07-13 02:33:19 -0500 )edit

answered 2014-11-26 18:48:44 -0500

Ryohei Ueda gravatar image

I compiled openni2 and openni2_camera from source and it works

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-11-12 20:44:38 -0500

Seen: 2,672 times

Last updated: Nov 26 '14