Ask Your Question
1

roslaunch openni2_launch failed on raspberry pi

asked 2015-04-07 03:02:50 -0600

Dragon Qu gravatar image

updated 2015-04-07 11:17:16 -0600

I installed openni2_launch from kalectro OpenNI2 It run well and simpletest worked fine.

I compiled openni2_launch and openni2_camera in raspberry pi. When run the command following, it failed at [camera/driver-2] process. Who can help to figure out how to fix it?

  roslaunch openni2_launch openni2.launch

... logging to /root/.ros/log/c95bdbb4-dccd-11e4-a09a-085700ac6da0/roslaunch-raspberrypi-11561.log
Checking log directory for disk usage. This may take awhile.
Press Ctrl-C to interrupt
Done checking log file disk usage. Usage is <1GB.

started roslaunch server http://raspberrypi:33096/

SUMMARY
========

PARAMETERS
 * /camera/camera_nodelet_manager/num_worker_threads: 4
 * /camera/depth_rectify_depth/interpolation: 0
 * /camera/driver/auto_exposure: True
 * /camera/driver/auto_white_balance: True
 * /camera/driver/color_depth_synchronization: False
 * /camera/driver/depth_camera_info_url: 
 * /camera/driver/depth_frame_id: camera_depth_opti...
 * /camera/driver/depth_registration: False
 * /camera/driver/device_id: #1
 * /camera/driver/rgb_camera_info_url: 
 * /camera/driver/rgb_frame_id: camera_rgb_optica...
 * /rosdistro: indigo
 * /rosversion: 1.11.10

NODES
  /camera/
    camera_nodelet_manager (nodelet/nodelet)
    depth_metric (nodelet/nodelet)
    depth_metric_rect (nodelet/nodelet)
    depth_points (nodelet/nodelet)
    depth_rectify_depth (nodelet/nodelet)
    depth_registered_sw_metric_rect (nodelet/nodelet)
    driver (nodelet/nodelet)
    points_xyzrgb_sw_registered (nodelet/nodelet)
    rectify_color (nodelet/nodelet)
    register_depth_rgb (nodelet/nodelet)
  /
    camera_base_link (tf/static_transform_publisher)
    camera_base_link1 (tf/static_transform_publisher)
    camera_base_link2 (tf/static_transform_publisher)
    camera_base_link3 (tf/static_transform_publisher)

ROS_MASTER_URI=http://hqu-desktop:11311

core service [/rosout] found
process[camera/camera_nodelet_manager-1]: started with pid [11628]
[ INFO] [1428356333.975372916]: Initializing nodelet with 4 worker threads.
process[camera/driver-2]: started with pid [11640]

    [FATAL] [1428356339.002887237]: Service call failed!

    [camera/driver-2] process has died [pid 11640, exit code 255, cmd /opt/ros/indigo/lib/nodelet/nodelet load openni2_camera/OpenNI2DriverNodelet camera_nodelet_manager ir:=ir rgb:=rgb depth:=depth depth_registered:=depth_registered rgb/image:=rgb/image_raw depth/image:=depth_registered/image_raw __name:=driver __log:=/root/.ros/log/c95bdbb4-dccd-11e4-a09a-085700ac6da0/camera-driver-2.log].
    log file: /root/.ros/log/c95bdbb4-dccd-11e4-a09a-085700ac6da0/camera-driver-2*.log

process[camera/rectify_color-3]: started with pid [11647]
process[camera/depth_rectify_depth-4]: started with pid [11654]
process[camera/depth_metric_rect-5]: started with pid [11661]
process[camera/depth_metric-6]: started with pid [11670]
process[camera/depth_points-7]: started with pid [11677]
process[camera/register_depth_rgb-8]: started with pid [11684]
process[camera/points_xyzrgb_sw_registered-9]: started with pid [11690]
process[camera/depth_registered_sw_metric_rect-10]: started with pid [11697]
process[camera_base_link-11]: started with pid [11704]
process[camera_base_link1-12]: started with pid [11709]
process[camera_base_link2-13]: started with pid [11714]
process[camera_base_link3-14]: started with pid [11719]
edit retag flag offensive close merge delete

Comments

Hi! Same Problem here with hydro on a PcDuino v3. Any solutions found on your side?

Matthieu Muschinowski gravatar imageMatthieu Muschinowski ( 2015-04-17 03:27:52 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2015-04-20 03:56:32 -0600

Matthieu Muschinowski gravatar image

Hello!

Found a solution to this problem on a PcDuino V3 by resolving Path settings for Openni2 following this post: https://github.com/kalectro/openni2_c...

edit flag offensive delete link more

Comments

Hi there, this seems to work for me using rosrun as stated in the link you posted. But openni2_launch still has the same error as in the question ?

miguel gravatar imagemiguel ( 2015-08-15 03:06:43 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2015-04-07 03:02:50 -0600

Seen: 554 times

Last updated: Apr 20 '15