No definition of [geometry_msgs] for OS [debian] [closed]

asked 2015-07-13 03:08:37 -0500

Kazuki Kadonaka gravatar image

updated 2015-07-13 07:49:49 -0500

gvdhoorn gravatar image

Hi

Installing ROS Hydro on Raspberry Pi

I'm following the tutorial at http://wiki.ros.org/ROSberryPi/Settin...

I ran the following command

$ cd ~/ros_catkin_ws/src
$ roslocate info turtlesim | rosws merge -
$ rosws update
$ cd ..
$ rosdep install  --from-paths src --ignore-src --rosdistro hydro -y --os=debian:wheezy
$ ./src/catkin/bin/catkin_make_isolated --install

$ rosdep install --from-paths src --ignore-src --rosdistro hydro -y --os=debian:wheezy caused an error

ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies:
turtlesim: No definition of [geometry_msgs] for OS [debian]

I don't know how to resolve Please teach me

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-11 20:33:38.494390

Comments

No real solution, but have you tried with downloading the package manually, basically as described here with git clone https://github.com/ros/common_msgs.git --branch hydro-devel

mgruhler gravatar imagemgruhler ( 2015-07-13 04:05:45 -0500 )edit

Did you ever find a solution to this? I am running into the same issue trying to install ROS Indigo on a Raspberry Pi 2

bigbrett gravatar imagebigbrett ( 2016-02-18 18:19:37 -0500 )edit

Working through this myself; it's somehow related to http://answers.ros.org/question/66750... What's interesting is the fix mentioned there has been since removed from the code base )

matpalm gravatar imagematpalm ( 2016-03-24 00:37:20 -0500 )edit