Ask Your Question
0

Registered depth image from Kinect using openni is all zeros (Indigo)

asked 2014-11-11 17:09:42 -0500

davidjoh gravatar image

I'm trying to pull point/depth cloud data off of a Kinect on a turtlebot, and I'm having problems. I start the turtlebot and openni with the standard commands (in different terminals):

roslaunch turtlebot_bringup minimal.launch
roslaunch openni_launch openni.launch

and open up rviz on my control workstation. So far, so good - everything starts without errors, and I can plot a pointcloud using the raw depth data. Unfortunately, what I actually need is the registered depth data. This isn't available unless I set depth_registration:=true (either using the reconfigure tool or by restarting openni). If I do this, the registered depth data does show up, but the depth image is all zeros and the pointclouds are full of NaNs.

I'm running Ubuntu 14.04 on a 32-bit netbook, and using ROS Indigo (installed from PPA, except for the rocon, kobuki and turtlebot packages, which I compiled).

I know this is not a new problem (see http://answers.ros.org/question/53706... ), but all the other posts I've been able to find were from a year ago, with old versions of Ubuntu/ROS, and it seems like the issue was eventually resolved by software updates... at least until now.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2015-10-26 21:52:50 -0500

Loneflyer gravatar image

You should try freenect, it worked for me.

 roslaunch freenect_launch freenect.launch

If the error was resolved, how did you do it? Please post.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-11-11 17:09:42 -0500

Seen: 455 times

Last updated: Oct 26 '15