ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

error while building fovis_ros

asked 2014-11-07 14:16:59 -0500

Bhargav gravatar image

Hi tried to build package from this source. [git] I have successfully built libfovis library. But after this i am getting the following error.

"A lot of code" followed by

collect2: ld returned 1 exit status
make[2]: *** [/home/bhargav/catkin_ws/devel/lib/fovis_ros/fovis_stereo_odometer] Error 1
make[1]: *** [fovis/fovis_ros/CMakeFiles/fovis_stereo_odometer.dir/all] Error 2

Please help me build this package successfully.

edit retag flag offensive close merge delete



Hi Bhargav,

only with those lines makes it impossible to tell. Could you please paste the full output somewhere and give us the link? For example at

Miquel Massot gravatar image Miquel Massot  ( 2014-11-10 01:45:43 -0500 )edit

@Miquel thank you! i have posted the error here . Also i was not aware of gist. Thanks for it too.

Bhargav gravatar image Bhargav  ( 2014-11-10 15:35:31 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-11-11 03:12:55 -0500

Miquel Massot gravatar image

As the issue is related to our ros node, I'll follow the discussion at . Please, refer to the github issue for more information.

edit flag offensive delete link more


thanks a lot! oit worked! :)

Bhargav gravatar image Bhargav  ( 2014-11-11 04:32:34 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-11-07 14:16:59 -0500

Seen: 241 times

Last updated: Nov 11 '14