ROS Resources: Documentation | Support | Discussion Forum | Service Status | Q&A answers.ros.org
Ask Your Question
0

Kinect Installation and Setup on ROS [Updated]

asked 2014-11-01 14:32:45 -0600

luketheduke gravatar image

updated 2015-02-23 16:40:34 -0600

Do I need any drivers to run the kinect on ROS? I ran sudo apt-get install ros-indigo-openni* and it downloaded 5mb of files. Then I tried following the tutorial at the wiki but when I ran the first command it said "[ Info] ... No Devices Connected ..." . lsusb shows up with the xbox nui camera and audio and a microsoft device on bus 1.... I'm using the XBOX 360 kinect and power cord from microsoft... What am I doing wrong here? Thanks,

Update: I have a kinect model 1473. Does that make any difference

When I run hsoltani's answer I still get the no devices connected error

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
3

answered 2014-11-10 22:41:34 -0600

corb gravatar image

updated 2014-11-10 22:43:23 -0600

I tried a number of things, so not sure what the exact combo that made it work was, but I think this should work:

A) sudo apt-get install ROS-Indigo-OpenNI-Launch (probably similar to what you installed)

B) Use step 3 from this for the drivers: http://www.20papercups.net/programmin...

C) Play with it: http://wiki.ros.org/openni_launch/Tut...

If that does work, please comment.

edit flag offensive delete link more

Comments

work for me, ubuntu 14.04 ros indigo

science00000 gravatar imagescience00000 ( 2017-03-01 20:57:41 -0600 )edit

work for me too, ubuntu 14.04 ros indigo But I start from step 2, or it will fail.

JarvisRobot gravatar imageJarvisRobot ( 2017-08-04 06:42:11 -0600 )edit
4

answered 2014-12-01 11:17:24 -0600

Kaplan gravatar image

Hi!

Openni_launch does not work anymore under Indigo for Kinect , but freenect_launch does. So install freenect_launch and libfreenect :

sudo apt-get install libfreenect-dev

sudo apt-get install ros-indigo-freenect-launch

Then call :

roslaunch freenect_launch freenect.launch

If it still does not work , disconnect Kinect from usb and plug again.

One more thing , it didn't work for me when Kinect was connected through an USB 2.0 hub but directly in USB 3.0 input of pc.

Source: http://wiki.ros.org/openni2_launch

"This package contains launch files for using OpenNI-compliant devices in ROS. It supports the Asus Xtion, Xtion Pro, and multiple version of the Primesense 1.08 and 1.09 cameras. It does NOT support any versions of the Kinect. freenect_launch or openni_launch is the recommended package for using a Kinect with ROS."

edit flag offensive delete link more

Comments

It still says no devices connected... A device made by microsoft with code: 045e:02c2 showed up when i executed lsusb.... any other ideas? Also when I run roslaunch freenect_launch freenect.launch I get No devices connected.... waiting for devices to connect

luketheduke gravatar imageluketheduke ( 2014-12-02 15:49:06 -0600 )edit

Actually it says that openni2 does not support any of Kinects. openni should support. btw. I was encountering with the same problem but freenect_launch solved it. I am able to get rgb and depth data On the other side I have to change lacun files which calls openni_launch as default with freenect

skywalker gravatar imageskywalker ( 2015-03-18 13:32:09 -0600 )edit
1

To solve my problem I also had to install the avin2 drivers. That made it work. Thanks for all your help!

luketheduke gravatar imageluketheduke ( 2015-03-23 15:35:19 -0600 )edit
1

Hi luketheduke. I am trying to interface kinect to ROS indigo and am facing similar problems. Could you please tell me the entire procedure all over so that i could know where i am going wrong.

Nimisha gravatar imageNimisha ( 2015-03-25 07:17:15 -0600 )edit

@Namisha I made a blog post detailing how I installed the necessary software. See it here http://goo.gl/zr3QiG.

luketheduke gravatar imageluketheduke ( 2015-03-25 17:28:48 -0600 )edit
1

What I get afert luanching freenect is just the following message [INFO] [1428079238.372035547]: Stopping device RGB and Depth stream flush. And I don't know what does it means,so is still kinect having troubles ? Because I also run rviz, trying to see an image

soichirutk gravatar imagesoichirutk ( 2015-04-03 11:55:03 -0600 )edit
1

I get same log, but it didn't affect anything. I can run RViz without problems. No idea why it comes out.

skywalker gravatar imageskywalker ( 2015-04-03 13:53:46 -0600 )edit

@soichirutk I get the same thing as @skywalker. I don't have any problems with it. Just try restarting rviz if it still doesn't show up.

luketheduke gravatar imageluketheduke ( 2015-04-03 14:11:10 -0600 )edit
1

answered 2014-11-10 23:10:03 -0600

hsoltani gravatar image

updated 2014-11-10 23:10:47 -0600

What's the model number of your kinect? Kinect 1473 doesn't work with openni2. Remove ros-indigo-openni2-launch and ros-indigo-openni2-camera. Try to install ros-indigo-openni-launch and ros-indigo-openni-camera. Then following the tutorial and launch the OpenNI driver like this:

roslaunch openni_launch openni.launch

edit flag offensive delete link more

Comments

I tried that but it still doesn't work... What now?

luketheduke gravatar imageluketheduke ( 2015-02-24 14:49:49 -0600 )edit
0

answered 2017-04-09 19:26:10 -0600

CGann gravatar image

just wanted to add to the above- I had to change directory to get it to launch. in a new window enter "cd /opt/ros/indigo/share/freenect_launch/launch" then "roslaunch freenect.launch" But I'm a total newb.

edit flag offensive delete link more

Comments

Thanks for your input, but next time, please consider putting it as a comment. cd to the directory the launch file is in is not necessary if you source the /opt/ros/indigo/setup.bash file. Then you can just use roslaunch without cd. Hope this helps!

luketheduke gravatar imageluketheduke ( 2017-04-10 17:21:05 -0600 )edit

Don't forget to include both the package name and the launch file: roslaunch freenect_launch freenect.launch

cyberguy42 gravatar imagecyberguy42 ( 2017-11-15 18:06:32 -0600 )edit
0

answered 2017-01-26 15:17:04 -0600

han88 gravatar image

I did everything mentioned in http://goo.gl/zr3QiG but if I run roslaunch freenect_launch freenect.launch i'm not able to connect to Kinect at all... ...INFO] [1485464131.648351596]: Searching for device with index = 1 if I run freenect-glview I get:

Number of devices found: 1 Could not claim interface on camera: -5 (libusb_ERROR_NOT_FOUND) Failed to open camera subdevice or it is not disabled.Failed to open motor subddevice or it is not disabled.Failed to open audio subdevice or it is not disabled.Could not open device...

This problem occurs only on my intel nuc, neither on my laptop nor on my raspiIII

Any ideas?

edit flag offensive delete link more

Comments

Welcome to ROS Answers! This isn't an answer to the question above, so I suggest you post a question and tag it with kinect or openni Your error message suggests that you are missing libusb

luketheduke gravatar imageluketheduke ( 2017-03-02 17:35:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

6 followers

Stats

Asked: 2014-11-01 14:32:45 -0600

Seen: 61,259 times

Last updated: Apr 09