Ask Your Question
4

Building indigo on 14.10

asked 2014-10-27 20:16:14 -0600

Fullmetal99012 gravatar image

Is it possible to build indigo on Utopic.

I have to run Utopic due to several issues that were solved in 14.10.

I tried the build from source, but I get

gazebo_ros: No definition of [gazebo] for OS version [utopic]
gazebo_plugins: No definition of [gazebo] for OS version [utopic]

edit retag flag offensive close merge delete

5 Answers

Sort by ยป oldest newest most voted
2

answered 2014-10-30 21:28:13 -0600

ahendrix gravatar image

There are two files you need to create to set up local rosdep rules on your machine:

/etc/ros/rosdep/local.yaml, with the contents (note that the formatting and indentation in this file are important):

gazebo_ros:
    ubuntu: []
gazebo_plugins:
    ubuntu: []

And /etc/ros/rosdep/sources.list.d/10-local.list with the contents:

yaml file:///etc/ros/rosdep/local.yaml
edit flag offensive delete link more

Comments

Thank you!!

Fullmetal99012 gravatar imageFullmetal99012 ( 2014-11-06 13:26:05 -0600 )edit

ahendrix- I too try to build from source on utopic and ran into the above error message on gazebo, e.g. "ERROR: the following packages/stacks could not have their rosdep keys resolved to system dependencies: gazebo_ros: no def... gazebo_plugins..." I tried your suggestion still the same error mesg

oscillative gravatar imageoscillative ( 2014-11-12 08:12:58 -0600 )edit

After you make these changes, you need to run rosdep update.

ahendrix gravatar imageahendrix ( 2014-11-12 14:04:49 -0600 )edit

OK, I tried "rosdep update", even after wiping and starting over with source build, but still unable to move pass the gazebo error.. I copied the pasted above into respective files you indicated, with root:root permission and readable by all.. I'm using utopic w/ ROS utopic (not trusty) repository?

oscillative gravatar imageoscillative ( 2014-11-13 08:26:39 -0600 )edit

I am also getting the OPs error. I just installed gazebo from source because I couldn't find any pre-built packages on Ubuntu Utopic.

I created the local.yaml and the 10-local.list files as you described and the error is still not resolved.

How to fix this?

Bidski gravatar imageBidski ( 2014-11-27 16:01:53 -0600 )edit

Using that trick dependency checking passed. Unfortunately gazebo is still missing for compilation hence it fails. I couldn't find a clean way to install gazebo using ubuntu tools (apt dependencies broken) so it was necessary to take it directly from http://gazebosim.org/ . Version 5 seems to work.

georg l gravatar imagegeorg l ( 2015-04-06 14:13:52 -0600 )edit
0

answered 2014-10-30 19:27:50 -0600

Fullmetal99012 gravatar image

Is there any documentation on how to create a rosdep rule and setting that up.

edit flag offensive delete link more
0

answered 2015-03-01 12:57:41 -0600

emccann gravatar image

I was able to get all the way through catkin_make_isolated. Instructions @ https://gist.github.com/nuclearmistak...

edit flag offensive delete link more
0

answered 2015-04-06 13:41:28 -0600

georg l gravatar image

I had some issues with the installation of the PCL. Adding the ppa solved it for me.

edit flag offensive delete link more
0

answered 2014-10-30 18:13:42 -0600

tfoote gravatar image

Most of ROS will probably work on Utopic. However there are likely missing dependencies or slightly changed dependencies.

Currently Gazebo has not been released for utopic, so that's in the missing camp. I know the gazebo team is working on making a release for utopic, but until that time if you want gazebo you'll have to install it from source and create a rosdep rule with an empty list for gazebo on utopic on your local machine.

edit flag offensive delete link more

Comments

Thank you!! I will keep that in mind. for right now, the actual robot computer is running 14.04, and I'm using a VM under windows with 14.04 and ROS.

Fullmetal99012 gravatar imageFullmetal99012 ( 2014-11-06 13:25:59 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-27 20:14:09 -0600

Seen: 2,528 times

Last updated: Mar 01 '15