Ask Your Question
0

Problems with hector_slam Tutorials MappingUsingLoggedData

asked 2014-10-23 06:04:53 -0500

Morpheus gravatar image

updated 2014-10-26 07:42:35 -0500

I am trying to run : hector_slam Tutorials MappingUsingLoggedData with Hydro. After I launch everything, I don't get any thing on Rviz. Here is the warning that I am getting:

edit retag flag offensive close merge delete

Comments

can you write more about error like commands used , rqt_graph, frames.pdf

ps: check you have proper frames and topic set to display map(incase just display problem.).

bvbdort gravatar image bvbdort  ( 2014-10-23 06:12:18 -0500 )edit

Here is the error that I am getting: [ INFO] [1414325137.230751975]: Geotiff node started SearchDir angle change too large SearchDir angle change too large SearchDir angle change too large SearchDir angle change too large

Morpheus gravatar image Morpheus  ( 2014-10-26 07:30:54 -0500 )edit

It shows scan match is not well, may be you are moving in long straight corridor or less laser scan rate or very fast moving vehicle.

bvbdort gravatar image bvbdort  ( 2014-10-26 14:40:54 -0500 )edit

I did manage to get the tutorial.launch running without any errors, but I still don't have anything showing on Rviz.

Morpheus gravatar image Morpheus  ( 2014-10-26 15:08:04 -0500 )edit

try saving map with mapsaver to check if problem with just visualisation.

bvbdort gravatar image bvbdort  ( 2014-10-26 16:06:51 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-28 21:22:07 -0500

Morpheus gravatar image

I was crowding my CPU too much, and was not giving mapsaver long enough. I shutdown some of the processes running on the CPU and everything worked ok.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-10-23 06:04:53 -0500

Seen: 494 times

Last updated: Oct 28 '14