Ask Your Question
0

How to install libopenni-sensor-pointclouds0 on Ubuntu 14.04?

asked 2014-09-30 20:50:41 -0500

wpd gravatar image

Hello, I just tried installing ros-indigo-desktop-full on my 64-bit Ubuntu 14.04 system, and the installation of libopenni-sensor-pointclouds0 failed with:

Setting up libopenni-sensor-pointclouds0 (5.1.0.41.1-1) ...
Installing new version of config file /etc/openni/GlobalDefaults.ini ...
niReg: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory
dpkg: error processing package libopenni-sensor-pointclouds0 (--configure):
 subprocess installed post-installation script returned error exit status 127

It seems that this issue is not unheard of, and this random web page page suggested that I

sudo ln -s /lib/x86_64-linux-gnu/libudev.so.1.3.5 /usr/lib/libudev.so.0

which I did, and which solved (for the moment) my installation problem. Needless to say, this feels like the worst way I could make this problem go away. As the libopenni-sensor-pointclouds0 package is maintained by Ubuntu folks (as opposed to ROS folks), I went ahead and opened this bug report to see what they would say.

I guess I should get to my question... :-)

Has anybody else had this problem?

In the mean time, if somebody else has this same problem and stumbles across this question, that person will have as much to go on as I do right now.

In the spirit of full disclosure, I just upgraded my 12.04 Ubuntu to 14.04. Perhaps something went a little flakey in that upgrade. I dunno.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-09-30 23:22:20 -0500

edit flag offensive delete link more

Comments

The questions _are_ similar, and both highlight that something seems a little broken, or misunderstood, with libopenni-sensor-pointclouds0, but that question highlights a Ubuntu package conflict, whereas mine highlights a broken installation (which may have been self-induced).

wpd gravatar image wpd  ( 2014-10-01 07:47:36 -0500 )edit

The issue was resolved here: https://github.com/ros/rosdistro/issu... If you're in the broken state the easiest thing to get unbroken is to use the force overwrite option in the answer. And then remove the older packages and make sure you've got the latest version which should conflict correctly

tfoote gravatar image tfoote  ( 2014-11-10 14:09:07 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-30 20:50:41 -0500

Seen: 900 times

Last updated: Sep 30 '14