Ask Your Question
0

rosdep initialisation error

asked 2014-09-25 07:25:50 -0500

Aracanid gravatar image

Hi, I've tried both today and yesterday incase it was a temporary thing, however I constantly recieve this error when trying to initialise rosdep:

ERROR: cannot download default sources list from:
https://raw.github.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list
Website may be down.

The other solutions I've seen assume that it's a proxy that is causing this but I am not using a proxy and I am able to ping github successfully as well as view the actual link it returns. I apologise if I have missed something simple here but I've been banging my head trying everything so far. Any help you could give would be greatly appreciated.

I'm running Ubuntu 14.04 LTS and using the Indigo Igloo version of ROS and my rosdep version is 0.10.30. If there is any further information you need just let me know.

edit retag flag offensive close merge delete

4 Answers

Sort by » oldest newest most voted
1

answered 2014-09-26 14:20:26 -0500

Aracanid gravatar image

updated 2014-10-06 14:48:11 -0500

I'm adding this edit in case others run into similar problems. The entire root of my problem seems to have been Virgin Media. Although it doesn't come up when you check for proxies or IP filtering, they do employ something in the background to filter for DMCA infringing sites so that they can block them. When I tethered my PC to my phone and used my phones data to initialise and update rosdep everything worked perfectly first time around.

Not sure if this will help everyone who had this problem but hopefully it does.

///// Manually adding the files has thankfully fixed this but I now get this error: reading in sources list data from /etc/ros/rosdep/sources.list.d ERROR: unable to process source [https://github.com/ros/rosdistro/raw/master/rosdep/osx-homebrew.yaml]: (https://github.com/ros/rosdistro/raw/...) Anyone got any ideas? ////

edit flag offensive delete link more

Comments

You need to change the contents of the sources list to point to your local copies not the ones on the web.

tfoote gravatar image tfoote  ( 2014-09-26 15:28:59 -0500 )edit

Thank you this worked for me!

joe930 gravatar image joe930  ( 2016-10-15 09:30:40 -0500 )edit
0

answered 2016-01-19 06:33:22 -0500

Petros gravatar image

Although you have your setup fixed, but for others finding this error message via google, they should verify their https_proxy and HTTPS_PROXY environment variables, that those should be unset, or set correctly. (An empty string in them would make rosdep fail.)

edit flag offensive delete link more
0

answered 2014-09-27 11:39:55 -0500

ama gravatar image

I have same problem

ERROR: cannot download default sources list from:
https://raw.github.com/ros/rosdistro/master/rosdep/sources.list.d/20-default.list
Website may be down.

have u solved it?

edit flag offensive delete link more

Comments

1

Please do not post comments as answers. This clearly is not an answer to the above question.

Dirk Thomas gravatar image Dirk Thomas  ( 2014-09-27 12:23:54 -0500 )edit
0

answered 2017-05-19 04:43:41 -0500

Donna gravatar image
  • check your proxy setting
  • verify proxies using wget, if the wget gave you certificate error. You may need to update the sytem date.

ERROR: cannot verify raw.githubusercontent.com's certificate, issued by ‘CN=DigiCert SHA2 High Assurance Server CA,OU=www.digicert.com,O=DigiCert Inc,C=US’: Issued certificate not yet valid. To connect to raw.githubusercontent.com insecurely, use `--no-check-certificate'.

  • update date

sudo date --set "19 MAY 2017 5:31 PM"

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-09-25 07:25:50 -0500

Seen: 1,416 times

Last updated: May 19 '17