Ask Your Question
0

Xacro problems in Indigo

asked 2014-09-23 13:05:05 -0500

Eric Schneider gravatar image

Hi,

I recently installed Indigo on a fresh 14.04 install after working in Hydro for a while, and xacro code that used to work no longer works. When I simply try to run xacro.py I get errors complaining about kobuki_description, which the internet doesn't seem to know much about. Any help?

’$:’rosrun xacro xacro.py neato.urdf.xacro > model.urdf
    Traceback (most recent call last):
      File "/opt/ros/indigo/share/xacro/xacro.py", line 60, in <module>
        xacro.main()
      File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 653, in main
        process_includes(doc, os.path.dirname(args[0]))
      File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 245, in process_includes
        filename_spec = eval_text(elt.getAttribute('filename'), {})
      File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 484, in eval_text
        results.append(handle_extension(lex.next()[1][2:-1]))
      File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 472, in handle_extension
        return eval_extension("$(%s)" % s)
      File "/opt/ros/indigo/lib/python2.7/dist-packages/xacro/__init__.py", line 66, in eval_extension
        return substitution_args.resolve_args(str, context=substitution_args_context, resolve_anon=False)
      File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 299, in resolve_args
        resolved = _resolve_args(resolved, context, resolve_anon, commands)
      File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 312, in _resolve_args
        resolved = commands[command](resolved, a, args, context)
      File "/opt/ros/indigo/lib/python2.7/dist-packages/roslaunch/substitution_args.py", line 145, in _find
        pkg_path = rp.get_path(args[0])
      File "/usr/lib/pymodules/python2.7/rospkg/rospack.py", line 190, in get_path
        raise ResourceNotFound(name, ros_paths=self._ros_paths)

    rospkg.common.ResourceNotFound: kobuki_description
    ROS path [0]=/opt/ros/indigo/share/ros
    ROS path [1]=/home/eon-alone/catkin_ws/src
    ROS path [2]=/opt/ros/indigo/share
    ROS path [3]=/opt/ros/indigo/stacks
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2014-09-23 13:21:06 -0500

The problem is that kobuki_description apparently is not in your ROS_PACKAGE_PATH of your indigo-workspace. You'd get the exact same error if this was the case in hydro, so this isn't really indigo-specific.

Running

sudo apt-get install ros-indigo-kobuki

should fix the problem. Also see this related Q/A: http://answers.ros.org/question/19013...

edit flag offensive delete link more

Comments

That worked, thanks! It must not be installed as part of ros-indigo-desktop-full. Now I need to try and install the turtlebot stuff from source, because debs aren't available yet.

Eric Schneider gravatar image Eric Schneider  ( 2014-09-23 14:14:01 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-23 13:05:05 -0500

Seen: 1,654 times

Last updated: Sep 23 '14