Ask Your Question
0

Failed converting xacro to urdf

asked 2017-02-17 21:08:57 -0500

Chunting gravatar image

updated 2017-02-17 21:10:39 -0500

When I run the command rosrun xacro xacro.py ur5.urdf.xacro > ur5.urdf, the result is not as good as I expected.

<robot xmlns:xacro="http://www.ros.org/wiki/xacro"> </robot>

edit retag flag offensive close merge delete

Comments

Could I please ask you to not cross-post questions like these to both ROS Answers and the package's issue tracker (universal_robot#288)? Besides bad etiquette, it leads to duplication of effort and reduced visibility of solutions.

gvdhoorn gravatar image gvdhoorn  ( 2017-02-18 04:48:12 -0500 )edit

Thanks for your kind remainder. I published this issue here firstly, then I think Universal_robot is the more suitable category, so I pulbished a second time. Sorry for my mistake and I will pay attention to your advice. Thanks.

Chunting gravatar image Chunting  ( 2017-02-18 08:47:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-02-17 21:37:00 -0500

dhood gravatar image

Maybe try the ur5_robot.urdf.xacro file instead because I think that ur5.urdf.xacro just defines the macro, and the ur5_robot.urdf.xacro uses the macro here: https://github.com/ros-industrial/uni...

edit flag offensive delete link more

Comments

1

This is indeed the cause. ur5.urdf.xacro is not a top-level xacro, but only defines a macro. The ur5_robot.urdf.xacro is the one instantiating the model, and should those be used.

See also universal_robot#288.

gvdhoorn gravatar image gvdhoorn  ( 2017-02-18 04:50:02 -0500 )edit

Thank you for your help, it works now. That is indeed the cause.

Chunting gravatar image Chunting  ( 2017-02-18 08:40:32 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2017-02-17 21:08:57 -0500

Seen: 506 times

Last updated: Feb 17 '17