Ask Your Question
0

Can I use Stage 3.x.x with ROS Hydro ??

asked 2014-09-19 08:27:39 -0600

tonyParker gravatar image

Most of the tutorials I found is for stage version 3.x.x.. But Since Fuerte stage version is 4.x.x.

I use Ubuntu 12.04 and on this version ROS Electric can not be installed.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-09-19 18:09:55 -0600

nfattahi gravatar image

Unfortunately the Stage package is poorly documented. But I've used Stage 4.x.x with Hydro before. I recall there were some minor changes I had to make to my .world files (adding a new dimension to some variables) to make them work with the new version. But other than that everything seemed to work fine.

edit flag offensive delete link more

Comments

I want to simulate Neato robot (LIDAR Sensor) or roomba with laser sensor but Stage 4.x.x has replaced laser with ranger and I am not very good in stage version difference and make edition in code. But I try

tonyParker gravatar imagetonyParker ( 2014-09-19 18:47:46 -0600 )edit

You're correct. Modifying the config files should be fairly straight forward as I recall. There's always help on ROS Answers if you run into issues!

nfattahi gravatar imagenfattahi ( 2014-09-19 20:12:00 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-09-19 08:27:39 -0600

Seen: 77 times

Last updated: Sep 19 '14