Ask Your Question
0

Is (Non RGB) Xtion Pro Supported?

asked 2014-08-28 16:08:49 -0600

skyzorg gravatar image

updated 2014-09-11 10:42:08 -0600

Hi, I have an Xtion Pro Sensor (non 'Pro-Live' version, without RGB camera) and am trying to run:

roslaunch openni_launch openni.launch

It dies immediately with with 'Service Call Failed!' errors.

I'm running Hydro on Ubuntu 12.04. Before I start delving into messing with parameters, wondering if anyone has managed to get the non-rgb Xtion Pro depth camera running with the openni_camera package? Or is it simply not supported?

(I also have a the Pro-Live RGB version of the sensor and it works fine on the same system)

EDIT: The underlying problem was a symbol lookup error which I solved by updating my system. Now I'm running openni2_launch and the camera is recognized, but I'm getting this error on launch:

[ERROR] [1409344784.275581907]: Unsupported color video mode - Resolution: 640x480@30Hz Format: RGB888

and this error when I add a PointCloud2 pointing to /camera/depth/points in Rviz:

[ INFO] [1409345247.761731749]: Starting depth stream.
[ INFO] [1409345248.232848173]: using default calibration URL
[ INFO] [1409345248.233537814]: camera calibration URL: file:///home/skyzorg/.ros/camera_info/depth_PS1080_PrimeSense.yaml
[ INFO] [1409345248.234404179]: Unable to open camera calibration file [/home/skyzorg/.ros/camera_info/depth_PS1080_PrimeSense.yaml]
[ WARN] [1409345248.235351909]: Camera calibration file /home/skyzorg/.ros/camera_info/depth_PS1080_PrimeSense.yaml not found.
[ERROR] [1409345248.237372380]: Rectified topic '/camera/depth/image_rect_raw' requested but camera publishing '/camera/depth/camera_info' is uncalibrated

I can't find any easy parameter change fix in the openni2.launch file, do I actually have to calibrate the camera? My Xtion Pro Live RGBD camera gives the same calibration warnings but not the last error shown above


EDIT2: Couldn't get non RGB Xtion Pro working under Xubuntu 12.04 and Hyrdo, I may have been running into this bug, as the error messages match exactly: https://github.com/ros-drivers/openni2_camera/issues/14

But a fresh of install of Xubuntu 14.04 and ROS Indigo did the trick, openni2_launch just works, with default settings.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-08-29 08:19:59 -0600

paulbovbel gravatar image

There shouldn't be any issues using the Xtion Pro. Can you update your question with output from lsusb -v, and relevant parts of dmesg when you plug in the sensor, and when you start openni? Keep in mind that newer ASUS sensors work with openni2 packages instead of openni.

edit flag offensive delete link more

Comments

Thanks! You've answered my basic compatibility question but I'm now I'm getting a calibration error, please see update to the question

skyzorg gravatar imageskyzorg ( 2014-08-29 16:06:58 -0600 )edit

I've only ever used the live version, and never had that issue, so I can't help you there. You could try running the calibration yourself and see if that helps.

paulbovbel gravatar imagepaulbovbel ( 2014-09-02 11:16:00 -0600 )edit

oh and try disabling the rgb_processing argument in openni2_launch, see if that gets rid of your error.

paulbovbel gravatar imagepaulbovbel ( 2014-09-02 11:18:37 -0600 )edit

tried everything short of actually calibrating in xubuntu 12.04 + hydro, nothing worked. BUT SUCCESS! >> after a fresh install of xubuntu 14.04 and ROS indigo, openni2_launch just works!

skyzorg gravatar imageskyzorg ( 2014-09-11 10:31:45 -0600 )edit

short of upgrading to Ubuntu 14.04 and Indigo (I am hoping to stay with Hydro on 12.04), has anyone found a solution?

joe.s gravatar imagejoe.s ( 2016-02-04 23:01:34 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-28 16:08:49 -0600

Seen: 1,248 times

Last updated: Sep 11 '14