ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

problem with move_base

asked 2014-08-25 05:54:14 -0500

arvind gravatar image

I am trying to control a bot with a lidar. When i run the launch files to switch on the lidar and obtain the cmd_vel values from rosserial based on odometry data, the cmd_vel is being published by the move_base.launch file. But, when i run the navigation stack which uses this data, I get an error that says-" THe bot cannot move forward". A little debugging tells me that the navigation stack subscribes to cmd_vel from move_base. But, the cmd_vel is not being output by the launch files itself. How to solve this problem?q

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2015-07-24 08:35:51 -0500

jbrown gravatar image

Topics such as cmd_vel are not published/subscribed to by launch files, they are (or should be) published/subscribed to by nodes. Try looking at your nodes and see what they publish (and what they don't).

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-08-25 05:54:14 -0500

Seen: 247 times

Last updated: Jul 24 '15