Ask Your Question
0

ERROR: cannot launch node of type [arbotix_python/arbotix_driver]: can't locate node [arbotix_driver] in package [arbotix_python]

asked 2014-08-21 05:05:55 -0500

ran95yu gravatar image

updated 2014-08-21 06:24:29 -0500

gvdhoorn gravatar image

Hello!I want ask a question:

when i roslaunch rbx1_bringup fake_pi_robot.launch, then the terminate display:

process[rosout-1]: started with pid [24627]
started core service [/rosout]
**ERROR: cannot launch node of type [arbotix_python/arbotix_driver]: can't locate node [arbotix_driver] in package [arbotix_python]**
process[robot_state_publisher-3]: started with pid [24640]
process[odom_left_wheel_broadcaster-4]: started with pid [24659]
process[odom_right_wheel_broadcaster-5]: started with pid [24672]

I don't know its reason,if you know,can you help me?

edit retag flag offensive close merge delete

Comments

Also: for future questions: please include ROS distribution, Linux distribution and any relevant package information.

gvdhoorn gravatar image gvdhoorn  ( 2014-08-21 06:21:43 -0500 )edit

hello, I have the same problem with you. Did you solve this problem? Could you tell me how?

dido_yf gravatar image dido_yf  ( 2014-12-18 04:42:05 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2014-08-21 22:04:37 -0500

ran95yu gravatar image

Thank you so much ! i have done this,i don't know why.But i turned "fuerte" to "groovy" yesterday,and now it's OK.

edit flag offensive delete link more
0

answered 2014-08-21 06:21:14 -0500

gvdhoorn gravatar image

Have you remembered to catkin_make and to source devel/setup.bash before trying to roslaunch things?

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-21 05:05:55 -0500

Seen: 795 times

Last updated: Aug 21 '14