ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
0

cannot launch node of type [arbotix_python/arbotix_driver]: arbotix_python

asked 2016-09-16 21:02:42 -0500

zakizadeh gravatar image

when i run :
roslaunch rbx2_bringup pi_robot_with_gripper.launch sim:=true

i have this error : ERROR: cannot launch node of type [arbotix_python/arbotix_driver]: arbotix_python ROS path [0]=/opt/ros/jade/share/ros ROS path [1]=/home/zakizadeh/catkin_ws/src ROS path [2]=/opt/ros/jade/share ROS path [3]=/opt/ros/jade/stacks ERROR: cannot launch node of type [arbotix_controllers/gripper_controller]: arbotix_controllers

please help me . how can i fix that ?

edit retag flag offensive close merge delete

Comments

I have the same error. Do you fix that?

zhaoxuan120 gravatar image zhaoxuan120  ( 2016-09-23 07:01:21 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2017-03-15 08:31:45 -0500

shawnysh gravatar image

try to do this to check

roscd arbotix_python

If you can't roscd the package, in other words, you don't install this package at all!

Then install the package, arbotix, shown in the error:

sudo apt-get install ros-indigo-arbotix

Hope it helps

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2016-09-16 21:02:42 -0500

Seen: 2,978 times

Last updated: Mar 15 '17