Ask Your Question
0

Cannot launch node of type, ROS Error

asked 2021-01-30 10:49:27 -0600

eddy gravatar image

Hey i get the following Error: ERROR: cannot launch node of type [arbotix_python/arbotix_driver]: Cannot locate node of type [arbotix_driver] in package [arbotix_python]. Make sure file exists in package path and permission is set to executable (chmod +x)

Does someone have an idea? if i locate arbotix_driver i get this :

/opt/ros/melodic/lib/arbotix_python/arbotix_driver

my launch file:

<launch>
<node name="arbotix" pkg="arbotix_python" type="arbotix_driver" output="screen">
<rosparam file="$(find realleg2)/config/realleg.yaml" command="load" />
</node>
</launch>

and the yaml file:

port: /dev/ttyUSB0
read_rate: 10
write_rate: 10
joints: {
servo1: {id: 1},
servo3: {id: 3},
servo5: {id: 5},
}

i also tried to reinstall and used catkin_build and source devel/setup.bash but still get this error...

I use ROS Melodic, Ubuntu 18

Thanks, Eddy

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2021-02-01 00:36:27 -0600

drtritm gravatar image

image description

In the source code of the package on github i found that the package_dir in the setup.py of your package is src. And your file "arbotix_driver" is not in that. It locates in bin directory.

edit flag offensive delete link more

Comments

does that mean it has to be transferred to the src folder? for it to work

Haris gravatar image Haris  ( 2021-07-04 06:36:42 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2021-01-30 10:49:27 -0600

Seen: 279 times

Last updated: Feb 01