Ask Your Question
0

How to install GPS common?

asked 2014-08-13 14:18:15 -0500

randylewis7 gravatar image

Hello, I'm currently trying to set up a GPS receiver and base station my boss purchased to work in ROS. It is a trimble Ag GPS 542 GNSS receiver ( http://ssmgps.com/pdf/AGPB_AgGPS542_B... ). I am trying to get it to work with the gps_common package, found here: http://answers.ros.org/question/75337...

However, when I install the package, using either

sudo apt-get install ros-hydro-gps-umd

or

git clone https://github.com/ktossell/gps_umd

I get a gps_common directory containing a cmake directory, a msg directory, and a package.xml, but no src directory or CMakeLists. Thus when I try to run nodes that are supposed to be within this package (for example,

rosrun gps_common utm_odometry_node

), it just freezes and doesn't work. I've encountered similar problems before when downloading random ros packages, and guess the solution must somehow have to do with somehow cmaking the cmake folders or files, but I cannot for the life of me figure out how to do this. If I cmake an individual file I get the error

 CMake Error: The source directory "/opt/ros/hydro/share/gps_common/cmake/<whatever_file_I_choose>.cmake" is a file, not a directory.

, and if I try to cmake the cmake directory, I get

  CMake Error: The source directory "/opt/ros/hydro/share/gps_common/cmake" does not appear to contain CMakeLists.txt.

Amyone know what I'm doing wrong here? Am I at least on the right track, or is there some other way to access these nodes short of manually creating my own package and copying the contents of each file into it from github, then catkin_making? (which I have tried successfully in the past, but am tired of doing)

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted
1

answered 2014-08-13 16:06:15 -0500

l0g1x gravatar image

updated 2014-08-13 16:08:23 -0500

Try git clone https://github.com/ktossell/gps_umd.git instead of just /gps_umd.

Or just do a cheap and dirty way with downloading the zip file, and extracting it to your workspace.

Either way, make sure you go into the root of gps_common package and run rosmake.

../catkin_ws/src/gps_common ---->> rosmake

Then build everything with catkin_make

../catkin_ws/ ---->> catkin_make

edit flag offensive delete link more

Comments

Ok, I removed the package and redownloaded it with the modified git clone line you suggested. Then I navigate into gps_common, and rosmake, but receive the following response: [ rosmake ] rosmake starting...
[ rosmake ] No package or stack specified. And current directory 'gps_common' is not a package name or stack name. [ rosmake ] Packages requested are: []
[ rosmake ] Logging to directory /home/randy/.ros/rosmake/rosmake_output-20140813-145138 [ rosmake ] Expanded args [] to: []
[ rosmake ] ERROR: No arguments could be parsed into valid package or stack names.

randylewis7 gravatar imagerandylewis7 ( 2014-08-13 16:54:16 -0500 )edit

I also tried rosmake gps (tab complete), and it filled in gpsd_client, which I then ran. No errors, but I'm not sure if this is what I wanted to do. Then I catkin_made just in case I did anything good. Again, I can find no reference in the build log to anything clontaining "gps."

randylewis7 gravatar imagerandylewis7 ( 2014-08-13 16:59:52 -0500 )edit

Although the error I receive when I try to run the node as originally described is slightly different (more complete now)!: [rospack] Error: stack/package gps_common not found [rosrun] Couldn't find executable named utm_odometry_node below

randylewis7 gravatar imagerandylewis7 ( 2014-08-13 17:00:58 -0500 )edit

manually download the zip, extract just the gps_common folder inside to zip into your own src folder, go to the gps_common folder in your src folder, type rosmake

l0g1x gravatar imagel0g1x ( 2014-08-14 17:06:50 -0500 )edit
2

answered 2017-03-24 09:34:07 -0500

updated 2017-03-24 09:36:20 -0500

As the maintainer of gps_umd has changed, make sure to clone the correct/most recent repo. I had to install libgps-dev, before I could build the gps_umd package. So here are the steps, which I made:

sudo apt-get install libgps-dev
cd catkin_ws/src
git clone https://github.com/swri-robotics/gps_umd.git
cd ..
catkin_make
edit flag offensive delete link more
1

answered 2015-08-25 12:03:17 -0500

Droter gravatar image

updated 2015-08-25 13:49:35 -0500

130s gravatar image

I am getting this error message when trying to build the gps_common:

Building CXX object gps_umd/gps_common/CMakeFiles/gps_common/utm_odometry_node.dir/src/utm_odometry_node.cpp.o
The bug is not reproducible, so it is likely a hardware or OS problem.
make[2]: *** [gps_umd/gpsd_client/CMakeFiles/gpsd_client.dir/src/client.cpp.o] Error 1
make[1]: *** [gps_umd/gpsd_client/CMakeFiles/gpsd_client.dir/all] Error 2

Ran this: sudo apt-get install gpsd

and it built okay.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-08-13 14:18:15 -0500

Seen: 3,592 times

Last updated: Mar 24 '17