Ask Your Question
0

Can I remove console_bridge dependency in class_loader when installing from source?

asked 2014-08-07 13:33:08 -0500

kurt.christofferson gravatar image

I am trying to install the indigo release "robot" set of packages on armhf from source.

For the class_loader package, the changelog states:

0.2.0 (2013-03-13)

  • use find_package for Poco/dl instead to make it work on other platforms
  • update Poco cmake file to include libdl on non-windows systems
  • No longer CATKIN_DEPEND on console_bridge

However the packages CMakeLists.txt still contains (on line 9)

find package(console_bridge REQUIRED)

Am I safe in removing the requirement?

Thanks in advance

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-08-07 14:07:50 -0500

ahendrix gravatar image

This is probably a bad idea. Even if class_loader isn't exporting the dependency on console_bridge, it's probably still depending on it internally.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-08-07 13:33:08 -0500

Seen: 76 times

Last updated: Aug 07 '14