ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A
Ask Your Question

rqt_graph topic statistics not working

asked 2014-07-30 09:47:04 -0500

dotcom gravatar image

updated 2014-07-30 18:33:04 -0500

William gravatar image

This is the documentation i'm following:

This feature is not working on my system. I can't find the reason why.

  • ROS Indigo
  • Ubuntu 14.04

Tested by creating some instances of the turtlesim package's executables.

Here's my result when using rqt_graph. You can see from the terminal window that the parameter is currently set to true


Please ignore the line under the terminal window.

edit retag flag offensive close merge delete


As answered below, besides setting the parameter to true, one needs to launch topic monitor and *tick* every statistics that is desired. 1. Launch rqt 2. Plugins -> topics -> topic monitor

dotcom gravatar image dotcom  ( 2014-07-31 04:32:02 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-07-30 18:44:40 -0500

William gravatar image

You may need to set the parameter before launching the nodes you want to introspect. I am able to monitor the statistics between turtlesim and the robot steering rqt plugin on my machine running indigo:

image description

Also, remember that you need to manually refresh the rqt Node Graph window using the refresh button.

edit flag offensive delete link more


Thank you, I think I was missing the ticks on Topic Monitor. The rqt_graph documentation led me to believe all statistics measurements would be active after setting the parameter to true. Enabling isn't the same as doing that, though.

dotcom gravatar image dotcom  ( 2014-07-31 04:29:33 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower


Asked: 2014-07-30 09:47:04 -0500

Seen: 1,694 times

Last updated: Jul 30 '14