ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Too fast circling during the localization

asked 2014-07-23 05:52:11 -0500

Moda gravatar image

updated 2014-07-24 06:08:50 -0500

When with rviz i inform the estimate localization, the robot start by circling very fasly. It is too fast, and may be dangerous. So how can I decrease the speed? I tried to reduce in the base_local_params_planner the acc_lim_th et the max_rotationnal_vel, but it doesn't work.

edit retag flag offensive close merge delete


What exactly are you doing? The "2D Pose Estimate" button in rviz should not move the robot at all.

dornhege gravatar image dornhege  ( 2014-07-24 08:44:39 -0500 )edit

I'm doing 2D Pose Estimate and 2D Nav Goal in rviz

Moda gravatar image Moda  ( 2014-07-24 08:49:08 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted

answered 2014-08-02 23:17:49 -0500

2ROS0 gravatar image

updated 2014-08-11 20:42:55 -0500

Just some sanity checks: Set the rotational recovery to false and see if that rotation stops. Also, try to manually move the robot around to check if it localizes in the map properly.

PS - I have also noticed that in if you reduce the max x and theta velocities below a certain limit, the robot tends to rotate. I do not know what causes this behavior.

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2014-07-23 05:52:11 -0500

Seen: 249 times

Last updated: Aug 11 '14