ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

robot clearance from walls

asked 2014-07-17 11:07:45 -0600

dreamcase gravatar image

hi, all,

I have been testing my robot for a while. there's a problem persists. the global plan would put the path along and close to the wall. especially at the corners, each time at the corners, my robot feels it's too close to the wall (I can see if from rviz), and initiates escape behaviour.

is there a way to move the path away from the walls? I am using default move_base global planner. or, does it help if I inflate the global cost map further? which parameter should I manipulate?

regards Ray

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-07-19 11:53:17 -0600

David Lu gravatar image

You're on the right track. If the robot is getting close enough that it is doing the recovery behaviors, then it's possible you're not setting the robot footprint correctly. What shape is your robot?

Changing the robot's footprint may change the minimum allowed distance. If you want to allow your robot to go closer, but prefer it to move farther, I would increase the inflation_radius and play with the cost_scaling_factor.

edit flag offensive delete link more


hi, David, it seems inflation_radius doesn't have too much influence on the costmap inflation. not too much impact when I changed it from default,0.55m to 2m, minimum clearance at the corner change from 0.5m to 0.7m. cost scaling factor seems reverse proportional to the inflation. smaller scaling factor gives wider inflation is it suppose so?

dreamcase gravatar image dreamcase  ( 2014-07-19 12:36:07 -0600 )edit

That sounds right. What is the shape of your robot, and what do you have the footprint set as?

David Lu gravatar image David Lu  ( 2014-07-19 17:07:36 -0600 )edit

the robot looks like a pentagon, footprint: [[0.1, 0.2], [0.25, 0.0], [0.1, -0.2],[-0.3, -0.2], [-0.3, 0.2]]. and when I set smaller scaling factors, it seems the local path planner is suppressed, as the obstacles are all inflated, and local planner cannot find a way out. is there a way to inflate the global costmap while leaving the local costmap untouched?

dreamcase gravatar image dreamcase  ( 2014-07-19 22:54:52 -0600 )edit

What distro are you using, and where are you changing the parameters?

David Lu gravatar image David Lu  ( 2014-07-22 08:59:30 -0600 )edit

I think it's ok now. the inflation_radius gives the radius within which objects will inflate, cost_scaling_factor is the one actually inflates the cost map.

dreamcase gravatar image dreamcase  ( 2014-07-22 09:43:59 -0600 )edit

I know it's been a while but I'll give it a try: what value did you use for cost_scaling_factor?

MariaKrgr gravatar image MariaKrgr  ( 2016-05-05 10:31:54 -0600 )edit

Question Tools

1 follower


Asked: 2014-07-17 11:07:45 -0600

Seen: 1,898 times

Last updated: Jul 19 '14