Ask Your Question
1

RVIZ *** glibc detected ***

asked 2014-07-17 10:05:36 -0600

AsifA gravatar image

Hi, I am using Hydro with Ubuntu 12.04 and unable to run rviz. I am getting following error when doing $ rosrun rviz rviz:

[ INFO] [1405607287.945120631]: rviz version 1.10.16
[ INFO] [1405607287.945243544]: compiled against OGRE version 1.7.4 (Cthugha) 
[ INFO] [1405607288.233226022]: Stereo is NOT SUPPORTED
[ INFO] [1405607288.233341114]: OpenGl version: 3 (GLSL 1.3).
*** glibc detected *** /home/asif/ROS_CatkinWS_Hydro/devel/lib/rviz/rviz: corrupted double-linked list: 0x00000000020422a0 ***
Inconsistency detected by ld.so: dl-open.c: 221: dl_open_worker: Assertion `_dl_debug_initialize (0, args->nsid)->r_state == RT_CONSISTENT' failed!

I removed rviz using $ sudo apt-get remove ros-hydro-rviz and tried to re-install using $ sudo apt-get install ros-hydro-rviz and it gave me an error:

E: Unable to locate package ros-hydro-rviz

Then I downloaded the source from github and managed to install it successfully using catkin_make but still getting same *** glibc detected *** error as above.

Any idea how to solve this problem! Thanks in advance.

PS: I found couple of similar questions asked earlier, for example this and this but did not found a solution.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-09-22 20:18:03 -0600

130s gravatar image

See the answer in this question where the error msg looks very similar (as you mentioned).

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-17 10:05:36 -0600

Seen: 469 times

Last updated: Sep 22 '14