Ask Your Question
0

/tf from /base_link to /camera_link

asked 2014-07-08 14:17:13 -0600

TSC gravatar image

Hi,

I'm using ccny_rgbd_tools which gives me a transform between /camera_link, which is the base_frame, and /odom, which is the fixed_frame.

I'm using MoveIt!, where I have a urdf model which as a camera_link and a base_link, which supposedly already gives a static_tf between them. I have a virtual_joint between camera_link and odom (which is floating, cause it is from a quadrotor).

Now running demo.launch (without the static_transform_publisher between camera_link and odom) I get this on the command line:

[ WARN] [1404846265.951041568]: No transform available between frame 'odom' and planning frame '/base_link' (Could not find a connection between 'base_link' and 'odom' because they are not part of the same tree.Tf has two or more unconnected trees.)

I have a /tf between odom and camera_link, and a /tf from base_link to camera_link, which builds up a tree. Why does it needs a /tf between base_link and odom?

Thanks in advance!

edit retag flag offensive close merge delete

Comments

can you try 'rosrun tf view_frames' and 'evince frames.pdf' and look or show the TF tree..this might give an idea of what exactly is happening down there.

sai gravatar imagesai ( 2014-07-08 21:07:17 -0600 )edit

Already did that! Odom doesn't even appear!

TSC gravatar imageTSC ( 2014-07-09 05:33:08 -0600 )edit

So is your ccny package running appropriately ? can you get the pose from 'rostopic echo \vo' and actually see the estimated pose in real time.

sai gravatar imagesai ( 2014-07-09 05:41:27 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-07-09 06:03:29 -0600

TSC gravatar image

updated 2014-07-09 06:06:46 -0600

ccny pkg is working properly. But now its working on Rviz also.

What I did was use robot_pose_ekf that receives the data from /vo and does the tf to base_footprint. Added a static_transform between the base_footprint and base_link and now I have the URDF position being updated in Rviz.

It kinda lags and sometimes has some jumps. Will probably have to add the IMU info also. Anyway, I would like to try the hector_localization package also to fuse other sensors, but I'm facing some difficulties due to to lack of documentation!

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-08 14:17:13 -0600

Seen: 1,106 times

Last updated: Jul 09 '14