Ask Your Question
0

rviz not working for sicklms

asked 2014-06-03 11:50:18 -0600

aniket gravatar image

updated 2014-06-03 11:50:50 -0600

i'm able to connect to my sensor, i am also able to see the data using rostopic echo /scan, However rosrun rviz rviz gives me a blank map. Please help

edit retag flag offensive close merge delete

Comments

1

Did you add the laser topic in rviz? What frame is the laser scan in? What is your fixed_frame in rviz?

jbinney gravatar imagejbinney ( 2014-06-03 13:39:22 -0600 )edit

these are my settings https://www.dropbox.com/s/z9a6hcspwipq19q/rviz.jpg the error under LaserScan Status is :- Transform [sender=/sicklms] For frame [laser]: Fixed Frame [base_laser] does not exist i tried editing the fixed_frame as map , still didnt work

aniket gravatar imageaniket ( 2014-06-10 15:23:22 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-06-10 15:46:17 -0600

jbinney gravatar image

This is a transform problem. The laser measurements are published in the base_laser coordinate frame, but rviz is trying to display them in the "laser" or "map" coordinate frame. Set your fixed frame to "base_laser" and you should see the data displayed. If you want to use another frame you need to make sure TF transforms are published to connect base_laser to your other frames (for instance by using http://wiki.ros.org/robot_state_publi... and a urdf)

edit flag offensive delete link more

Comments

my fixed fram is set to base_laser only, still no data. I do not understand what is supposed to be done. Sorry for being a noob but please help.

aniket gravatar imageaniket ( 2014-06-10 17:33:52 -0600 )edit

okay i just typed /laser in my global options-> fixed fram and it started working. Can you please tell me what was the mistake. Can you also tell me how do i manipulate the reading off the lms thanx (like how do i program it ?)

aniket gravatar imageaniket ( 2014-06-10 17:38:09 -0600 )edit

sounds like the laser is actually using the "laser" coordinate frame.... what do you see in the frame_id field of the laser message when you echo it?

jbinney gravatar imagejbinney ( 2014-06-10 17:51:26 -0600 )edit

Stuck at the same point. Have tried changing the Fixed Frame under Global Options from "map" to "base_laser" and "laser". I can see the data being published when I do rostopic echo /scan. Still no data showing up on map.

Tchanam gravatar imageTchanam ( 2015-01-22 14:06:17 -0600 )edit

Got it to work. Changed the Fixed Frame in Global Options to "laser" and the topic in LaserScan to "/scan".

Tchanam gravatar imageTchanam ( 2015-01-22 14:53:17 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-06-03 11:50:18 -0600

Seen: 1,075 times

Last updated: Jun 10 '14