Ask Your Question
1

Sick TiM310 Laser scanner not publishing to the topic

asked 2013-06-20 07:51:44 -0500

theblackpearl gravatar image

updated 2013-11-14 11:06:45 -0500

tfoote gravatar image

Hi,

I am trying to get my SICK TIM 310 laser working with ROS. I installed the ROS package sick_tim3xx in Fuerte on Ubuntu 12.04 When I run roslaunch sick_tim3xx sick_tim3xx.launch, I get following output and nothing gets published on the topic.

WARNING: received less fields than expected fields (actual: 124, expected: 580), ignoring scan

What could be possibly wrong with the laser? why is it giving only 124 fields instead of 580?
I'd really appreciate your help thanks

edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
1

answered 2013-06-24 23:56:41 -0500

updated 2013-06-25 00:11:34 -0500

I've solved this issue with @theblackpearl over email; here's a summary of the solution:

  • The mystery scanner in question is actually the new TiM 510 (which is not sold yet), even though it was labeled as a TiM 310.
  • It provides 91 measurements per scan over a 270° scan angle, instead of 271 (like the TiM 310 does). Also, it doesn't provide intensities. This is why each datagram is only 124 instead of 580 bytes.
  • The specs for the datagram format are yet to be released; I've written a quick hack to make the scanner work until proper support can be added to the sick_tim3xx package.
edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-06-20 07:51:44 -0500

Seen: 560 times

Last updated: Jun 25 '13