ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

ROS Indigo: Where is rqt_plot

asked 2014-06-03 07:42:12 -0500

fhurlbrink gravatar image

updated 2014-06-03 07:42:57 -0500

Hello, I try and want to run

$ rosrun rqt_plot rqt_plot

but it says

[rospack] Error: package 'rqt_plot' not found

In the rqt_gui it is not listed in the plugins. I have installed ros-indigo-desktop-full

Is it possible to get rqt_plot running?

edit retag flag offensive close merge delete

3 Answers

Sort by ยป oldest newest most voted

answered 2014-06-03 12:12:48 -0500

ahendrix gravatar image

It's possible that rqt_plot isn't included in the desktop-full variant for some reason. Have you tried installing it manually?

sudo apt-get install ros-indigo-rqt-plot

If it turns out that it's installable but isn't included in desktop-full, that's probably a bug in the desktop-full variant.

edit flag offensive delete link more


You're right, I was able to install manually on 14.04.

130s gravatar image 130s  ( 2014-06-03 12:50:23 -0500 )edit
ahendrix gravatar image ahendrix  ( 2014-06-03 13:22:01 -0500 )edit

Well, now I have installed it manually. But now, when I execute $ rosrun rqt_plot rqt_plot it says: [DEBUG] rqt_plot.plot: import of PyQtGraphDataPlot failed (trying other backends) qt_gui_main() found no plugin matching "rqt_plot"

fhurlbrink gravatar image fhurlbrink  ( 2014-06-04 02:31:06 -0500 )edit

@hurlbrink Please do not ask a new question in comment area, and try google your issue before you ask (I'm sure there's another question regarding your current issue). Also, be sure not to forget to mark this post as an answer if it solved your issue ;)

130s gravatar image 130s  ( 2014-06-04 09:56:48 -0500 )edit

OK, sorry. I'm new to ROS answers. I saw the PyQtGraph problem as a part of the rqt-plot issue. But now, I have googled it and so I found out, this is a separate issues independent from existing of rqt_plot in Indigo and solved it.

fhurlbrink gravatar image fhurlbrink  ( 2014-06-05 06:25:12 -0500 )edit

answered 2014-06-03 09:02:20 -0500

130s gravatar image

updated 2014-06-03 12:52:52 -0500

UPDATE: @ahendrix's answer seems to be correct.

Looks like debian file of rqt_plot is built but not yet synchronized into public repository. See debbuld status page I'm sure in the next public repository sync, it'll become available.

A concern and a tip:

edit flag offensive delete link more


The status page clearly indicates that there is a older version of rqt_plot in the public indigo repo...

ahendrix gravatar image ahendrix  ( 2014-06-03 12:10:56 -0500 )edit

answered 2014-07-03 22:07:57 -0500

DrBot gravatar image

I was able to do a sudo apt-get on ros-indigo-rqt-plot-common-plugins successfully

It opens, but so far I haven't figured out how to make it display anything. I keep getting errors on my topics having non-numeric data.

edit flag offensive delete link more


You should ask this as a new question rather than as an answer on an existing question. when you do ask a question, you should include some information about your topic names, topic types and the exact error message you're receiving.

ahendrix gravatar image ahendrix  ( 2014-07-04 02:59:38 -0500 )edit

Question Tools

1 follower


Asked: 2014-06-03 07:42:12 -0500

Seen: 1,364 times

Last updated: Jul 03 '14