Ask Your Question
0

getting started with rqt_plot

asked 2014-07-03 22:03:31 -0600

DrBot gravatar image

rostopic echo is telling me there is a topic gathering data

when I use the exact same topic name I get a message that "header" is non-numeric. Now on the command line display I see the 'value: " and the topic being updated. So I don't know the magic way to name the topic so rqt_plot can magically chop the title information and just get the data. I've tied various forms of appending the 'field" name to the topic without success.

BTW this is on indigo, Ubuntu 14.04.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-07-05 12:18:54 -0600

DrBot gravatar image

OK I figured it out -just add the variable name to the end of the node: if the variable was "range:" the full cli command would be like this:

rqt_plot /arduino/sensor/ir_front_center/range worked fine in both hydro and indigo.

rostopic /arduino/sensor/ir_front_center will reveal the variable of interest.

edit flag offensive delete link more

Comments

If running on multiple hosts you need to sync the time with chrony or use a common network derived time.

DrBot gravatar imageDrBot ( 2014-08-26 19:22:46 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-07-03 22:03:31 -0600

Seen: 495 times

Last updated: Jul 05 '14