Ask Your Question
1

Openni_launch has memory corruption error

asked 2014-05-26 06:34:25 -0600

jemalo gravatar image

I have a XBOX 360 kinect that is connected to my PC (Ubuntu 12.04 32bit and ROS hydro) via a USB 2.0 port. After that I started kinect with the following command:

> roslaunch openni_launch openni.launch

there is always an error concerning memory corruption. Below is the output information:

started core service [/rosout]
process[camera/camera_nodelet_manager-2]: started with pid [14062]
[ INFO] [1401120698.912195378]: Initializing nodelet with 4 worker threads.
process[camera/driver-3]: started with pid [14083]
process[camera/debayer-4]: started with pid [14101]
[ INFO] [1401120699.429355060]: Number devices connected: 1
[ INFO] [1401120699.429444163]: 1. device on bus 002:29 is a SensorV2 (2ae) from PrimeSense (45e) with serial id '0000000000000000'
[ INFO] [1401120699.430315901]: Searching for device with index = 1
process[camera/rectify_mono-5]: started with pid [14120]
[ INFO] [1401120699.462794100]: Opened 'SensorV2' on bus 2:29 with serial number '0000000000000000'
process[camera/rectify_color-6]: started with pid [14177]
process[camera/rectify_ir-7]: started with pid [14214]
*** glibc detected *** /opt/ros/hydro/lib/nodelet/nodelet: malloc(): memory corruption: 0x08de92c0 ***
process[camera/depth_rectify_depth-8]: started with pid [14244]
process[camera/depth_metric_rect-9]: started with pid [14258]
process[camera/depth_metric-10]: started with pid [14272]
process[camera/depth_points-11]: started with pid [14286]

There is nothing displayed in Rviz. I have already re-installed all packages and libraries whose name contains "openni", but the problem still exists. Thanks a lot in advance for any hint and help. -- zhaopeng

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2014-05-27 03:17:49 -0600

jemalo gravatar image

updated 2014-05-27 03:18:10 -0600

FYI, I have solved this problem by removing ros-hydro-nodelet* using apt-get and git-cloning the corresponding source packages (nodelet_core, perception_pcl and image_pipeline). After catkin making, openni_launch works perfectly.

edit flag offensive delete link more
0

answered 2018-04-08 19:09:38 -0600

130s gravatar image

updated 2018-09-27 19:43:19 -0600

Not the same package though, I've seen the similar error message happened when we compiled openni2_camera on Ubuntu 14.04 while core packages of ROS were not updated for awhile. We figured out that ABI incompatibility of a dependent package (this) caused it, so solution for us was to rebuild all the packages in our Catkin workspace.

In @jemalo's answer it was also a nodelet that seemed to be related, which I think may or may not be nothing but a coincidence.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-26 06:34:25 -0600

Seen: 814 times

Last updated: Sep 27 '18