Ask Your Question
0

error install indigo ROS on debian wheezy [closed]

asked 2014-05-18 07:47:53 -0500

maverh gravatar image

updated 2016-12-02 18:05:13 -0500

130s gravatar image

rosdep install --from-paths src --ignore-src --rosdistro indigo -y -r --os=debian:wheezy

Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libfltk-dev is a virtual package provided by:
  libfltk1.3-dev 1.3.0-8
  libfltk1.1-dev 1.1.10-14
You should explicitly select one to install.
E: Package 'libfltk-dev' has no installation candidate
ERROR: the following rosdeps failed to install
  apt: command [sudo apt-get install -y rosdep] failed
  apt: command [sudo apt-get install -y libcollada-dom2.4-dp-dev] failed
  apt: command [sudo apt-get install -y liblz4-dev] failed
  apt: command [sudo apt-get install -y libfltk-dev] failed
  apt: Failed to detect successful installation of [libcollada-dom2.4-dp-dev]
  apt: Failed to detect successful installation of [liblz4-dev]
  apt: Failed to detect successful installation of [rosdep]
  apt: Failed to detect successful installation of [libjpeg-dev]
  apt: Failed to detect successful installation of [libfltk-dev]

how can i solve this?


UPDATE

I have install the libcollada-dom2.4-dp-dev

rosdep install --from-paths src --ignore-src --rosdistro indigo -y -r --os=debian:wheezy

E: Package 'libfltk-dev' has no installation candidate
ERROR: the following rosdeps failed to install
  apt: command [sudo apt-get install -y rosdep] failed
  apt: command [sudo apt-get install -y libcollada-dom2.4-dp-dev] failed
  apt: command [sudo apt-get install -y liblz4-dev] failed
  apt: command [sudo apt-get install -y libfltk-dev] failed
  apt: Failed to detect successful installation of [libcollada-dom2.4-dp-dev]
  apt: Failed to detect successful installation of [liblz4-dev]
  apt: Failed to detect successful installation of [rosdep]
  apt: Failed to detect successful installation of [libjpeg-dev]
  apt: Failed to detect successful installation of [libfltk-dev]
edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by 130s
close date 2016-12-02 18:06:31.127806

Comments

Did you did that correctly : "When check-install asks for documentation you need to update the package name from "collada-dom" to "collada-dom-dev" otherwise the rosdep install wont find it" ?

Maya gravatar image Maya  ( 2014-05-19 05:11:15 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-05-18 08:32:05 -0500

Maya gravatar image

Install Hydro on Debian from source

I think you miss the Collada-dom library. Here failed apt: command [sudo apt-get install -y libcollada-dom2.4-dp-dev] the rosdep said it failed to apt-get it which is normal on Debian. Thus you should install it first from source. The explanation on how to do it is given in the above link.

Good luck !

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2014-05-18 07:47:53 -0500

Seen: 1,415 times

Last updated: Dec 02 '16