ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | Q&A answers.ros.org
Ask Your Question
6

generate_dynamic_reconfigure_options executed every build

asked 2014-05-15 08:36:12 -0500

Benny gravatar image

updated 2014-07-01 21:50:19 -0500

Hi, I noticed that in my project every node with dynamic_reconfigure is rebuilt even if there is no file change. Is this a known behaviour of catkin? Is there anyway to prevent it?

Thanking you, Benzun

Edit: I thought I solved this issue but everytime i run dynamic reconfigure the headers are created again in the folder /devel/include/package_name.

I am using ros hydro on Ubuntu 12.04. I am just building the dynamic_reconfigure tutorial from http://wiki.ros.org/dynamic_reconfigu...

Everytime i run the build i get the following

Generating dynamic reconfigure files from cfg/Tutorial.cfg: /home/bpwiselybabu/drc_workspace/devel/include/dynamic_tutorials/TutorialConfig.h /home/bpwiselybabu/drc_workspace/devel/lib/python2.7/dist-packages/dynamic_tutorials/cfg/TutorialConfig.py

Even though I have not edited the cfg/Tutorial.cfg file

This does not happen with ros messages though.

edit retag flag offensive close merge delete

Comments

1

This is not a known issue. If you want more help to figure out what is happening for you you might want to provide more information: Which version of ROS are you using? For which package do you experience the issue? What commands do you invoke, what is the actual output, what the expected?

Dirk Thomas gravatar image Dirk Thomas  ( 2014-05-21 09:35:27 -0500 )edit

Without more information, I don't see how anyone can help you.

joq gravatar image joq  ( 2014-05-24 04:53:01 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
7

answered 2014-07-02 00:48:19 -0500

ahendrix gravatar image

updated 2014-07-02 00:50:07 -0500

I've seen this happen when the class name that is generated doesn't match the file name that generated it.

This is noted in the tutorial that you link to:

"NOTE: The third parameter should be equal to the cfg file name, without extension. Otherwise the libraries will be generated in every build, forcing a recompilation of the nodes which use them."

edit flag offensive delete link more

Comments

I had the same issue on ubuntu 14.04 / ros indigo. This solved it.

drewm1980 gravatar image drewm1980  ( 2015-10-22 03:36:46 -0500 )edit
5

answered 2014-05-22 00:18:48 -0500

TommyP gravatar image

updated 2014-05-22 00:19:31 -0500

We had the same problem but we fixed it by adding _catkin in the following line in the cfg file:

from dynamic_reconfigure.parameter_generator_catkin import *

I had converted an old package to catkin and had missed that you needed _catkin here.

edit flag offensive delete link more

Comments

Similar issue I was upgrading an existing package in catkin. but I already made the change you suggested, yet it occurs.

Benny gravatar image Benny  ( 2014-05-22 07:58:48 -0500 )edit

I just tested to remove _catkin and then it re-generated the dynamic_reconfigure files each time I run catkin_make. I tested it on Hydro.

TommyP gravatar image TommyP  ( 2014-05-22 23:31:31 -0500 )edit

This solved my problem (the parameter name was already matching the cfg name). Thanks a lot :)

RaminYT gravatar image RaminYT  ( 2019-05-29 10:14:00 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

3 followers

Stats

Asked: 2014-05-15 08:36:12 -0500

Seen: 1,605 times

Last updated: Jul 02 '14