Ask Your Question
0

How do I install and build fovis_ros?

asked 2014-05-10 14:55:36 -0500

Rick Armstrong gravatar image

Hello,

I'm attempting to install and use fovis_ros, and I feel as though I'm missing something. I did the following in a top-level ROS workspace:

cd /src

sudo apt-get install ros-hydro-fovis

Apparently there's no binary package so I did a

git clone https://github.com/srv/fovis.git

This created

/src/fovis

/fovis

/fovis_ros

Then,

catkin_make

and I got

"The specified source space "/home/blah-blah-my-dirs/src/fovis/src" does not exist"

And indeed, ./fovis/fovis/src does not exist.

Reading here, I see "This stack contains two packages: libfovis and fovis_ros. The former contains a Makefile for downloading and building fovis, the latter contains the ROS wrapper for this library."

I was expecting that doing catkin_make would automagically go get libfovis and build it, but no soap.

Is this a bug, or a feature? :)

Thanks,

Rick

P.S. I also tried

sudo apt-get install libfovis,

and this installed fine, but still didn't help with building fovis_ros.

edit retag flag offensive close merge delete

Comments

I have the same problem after install libfovis.

CMake Error at /opt/ros/hydro/share/libfovis/cmake/libfovisConfig.cmake:141 (message): Project 'fovis_ros' tried to find library 'libfovis'. The library is neither a target nor built/installed properly. Did you compile project 'libfovis'?

Lili Meng gravatar image Lili Meng  ( 2014-10-27 21:16:27 -0500 )edit

Hi Lili,

It's been a while, but if I remember correctly, 1) pulling the Miquel's latest libfovis drop as of May 11 (see below), and 2) building libfovis in the top level of my ROS workspace fixed my problem.

Rick

Rick Armstrong gravatar image Rick Armstrong  ( 2014-10-28 00:04:39 -0500 )edit

Thanks a lot! It has been successfully compiled! :)

Lili Meng gravatar image Lili Meng  ( 2014-10-29 16:50:53 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-05-10 22:46:02 -0500

Miquel Massot gravatar image

Hi Rick,

could you please try putting ros-hydro-libfovis? If that does not work try instead downloading libfovis in your ws from https://github.com/srv/libfovis There may be something wrong with the debian package.

Can you please tell me which ROS distro are you using?

edit flag offensive delete link more

Comments

Miquel, I'm using hydro on Ubuntu 12.04 LTS. I installed ros-hydro-libfovis but fovis_ros still didn't find libfovis. I then downloaded the libfovis source to my ws as you suggested, and this fixed the problem. Next issue: compiling mono_depth_odometer.cpp fails, unable to find fovis_ros/FovisInfo.h

Rick Armstrong gravatar image Rick Armstrong  ( 2014-05-11 18:43:56 -0500 )edit

Also: thanks!

Rick Armstrong gravatar image Rick Armstrong  ( 2014-05-11 18:44:35 -0500 )edit

I added a message generation dependency to fovis_ros. Please update your package -> git pull. Good catch!

Miquel Massot gravatar image Miquel Massot  ( 2014-05-11 23:17:12 -0500 )edit

That did the trick, thanks!

Rick Armstrong gravatar image Rick Armstrong  ( 2014-05-12 18:32:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-05-10 14:55:36 -0500

Seen: 999 times

Last updated: May 10 '14