Ask Your Question
0

No depth data received from kinect on turtlebot?

asked 2014-05-10 13:59:44 -0600

randylewis7 gravatar image

updated 2014-10-24 13:50:52 -0600

ahendrix gravatar image

After running 3dsensor.launch on the turtlebot, I am trying to subscribe to the kinect topics, but am running into trouble. Although I can subscribe to topics like /scan and /camera/depth_registered/image_raw, they don't give me any values, like they should. /scan publishes the correct header type data, but then large arrays of what should be accurate data but are just Nan Nan Nan over and over. camera/depth_registered/image_raw publishes a bunch of 0's in place of data. camera/rgb/image color publishes properly, but /camera/depth/points publishes no messages. It seems there is a problem with publishing the topics that involve depth data, but i'm not sure why.

Note: I recently had a problem with the kinect wherin the turtlebot would tell me that "no devices were connected" when I ran 3d sensor.launch, even though the kinect was clearly plugged in. I solved this problem by removing everything on the turtlebot that had to do with the open_ni sensor kinect drivers, and then reinstalling them from online. Reading online about my current problem, I see that a common suggested fix is to do basically this, so I'm a little confused as to why reinstalling open_ni solved only the first but not the second problem (if that really is the fix).

Another note: the depth data is published correctly if I run the follower turtlebot follower tutorial instead of running 3dsensor.launch directly.

edit retag flag offensive close merge delete

Comments

Hi Lewis, I am having similar trouble with my device, Even it's plugged in, system gives an error "no devices were connected". How did you remove this issue? Can you please share the link here? Thank You, Sudeep

Sudeep gravatar imageSudeep ( 2014-05-11 13:37:29 -0600 )edit
1

In order to solve the problem you're having, I did apt-get remove OPEN_NI*, and then we reinstalled OPEN_NI from the repository online. And then I had to reboot and stuff but it worked

randylewis7 gravatar imagerandylewis7 ( 2014-05-14 09:36:54 -0600 )edit

Thank you very much I will try that :)

Sudeep gravatar imageSudeep ( 2014-05-14 11:17:37 -0600 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-10-24 10:58:13 -0600

There is a conflict with having both the depthclound and registered depthcloud launching at the same time. To view the depthcloud, set the registered depthcloud arguments to false when launching 3dsensors.launch

roslaunch turtlebot_bringup 3dsensor.launch depth_registered_processing:=false depth_registration:=false

You can then launch view_robot.launch as you normally would.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-05-10 13:59:44 -0600

Seen: 1,086 times

Last updated: Oct 24 '14