Ask Your Question
0

Teleop control not working in Turtlebot simulator

asked 2013-12-07 09:49:23 -0500

Stefano Primatesta gravatar image

updated 2013-12-07 09:50:17 -0500

I following this tutorial,

http:// wiki.ros.org/turtlebot_simulator/Tutorials/hydro/Explore%20the%20Gazebo%20world but teleop not working.

I'm using Gazebo 2.1.0 and ROS Hydro.

I used $roslaunch turtlebot_teleop keyboard_teleop.launch AND $roslaunch kobuki_keyop keyop.launch and there isn't error message. I have no idea why it doesn't work. I'm not sure if they've started on different servers and are unable to communicate.

edit retag flag offensive close merge delete

Comments

Please say what you are doing and what you expect to happen and what is happening so that we can reproduce the problem. Otherwise we cannot help you.

tfoote gravatar imagetfoote ( 2013-12-07 10:25:43 -0500 )edit

The problem is that following step by step tutorial I should drive the turtlebot by Keyboard. When I run Roslaunch nothing happens, I can't move turtlebot in Gazebo. It seems that Gazebo and turtlebot_teleop doesn't speak. I installed everything as the tutorial says.

Stefano Primatesta gravatar imageStefano Primatesta ( 2013-12-07 11:06:41 -0500 )edit

Are you keeping focus in the teleop window?

tfoote gravatar imagetfoote ( 2013-12-07 11:09:48 -0500 )edit

Yes, but nothing happens. Teleop indicates change of speed but Turtlebot is stopped.

Stefano Primatesta gravatar imageStefano Primatesta ( 2013-12-07 11:17:20 -0500 )edit

I'm getting the same problem, just following the teleop tutorial that Prima89 mentioned. I can see velocity commands are being published to the /cmd_vel_mux/input/teleop topic, but the Turtlebot doesn't respond. Perhaps it's a problem with cmd_vel_mux then? Or mobile_base_nodelet_manager?

Angus gravatar imageAngus ( 2013-12-08 10:44:45 -0500 )edit
1

The official ros release gazebo version is 1.9.2. Using gazebo 2.1.0 would be the problem. Can you try with gazebo version 1.9.2?

jihoonl gravatar imagejihoonl ( 2013-12-08 18:05:05 -0500 )edit

Works in Gazebo 1.9.1. Thanks very much jihoonl and tfoote! @Prima89: refer to this post for how to downgrade from Gazebo 2.1.0 to 1.9.1: http://answers.ros.org/question/101976/ros-hydro-desktop-full-installs-gazebo-current-instead-of-gazebo/

Angus gravatar imageAngus ( 2013-12-08 19:14:52 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-12-08 19:01:45 -0500

Angus gravatar image

Opps, looks like I accidentally upgraded Gazebo from 1.9.2 to 2.1.0 in the latest package update. I will try again with 1.9.2.

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2013-12-07 09:49:23 -0500

Seen: 1,325 times

Last updated: Dec 07 '13