map_store and /save_map -- turtlebot hydro [closed]

asked 2014-02-12 06:50:38 -0500

david.c.liebman gravatar image

I am having trouble with map_store. If I try using it and I don't have any kind of map the command just hangs. It says it's waiting for '/dynamic_map' but if I type 'rosrun map_store somename' and there's a map on /dynamic_map (I think there's a map there!!) I get the following error:

Waiting for /dynamic_map...
Waiting for /save_map...
Waiting for /list_maps...
Waiting for /delete_map...
Checking for duplicates...
Starting service...
Saving map as myname
Traceback (most recent call last):
  File "/opt/ros/hydro/lib/map_store/", line 43, in <module>
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rospy/impl/", line 435, in __call__
    return*args, **kwds)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rospy/impl/", line 515, in call
    responses = transport.receive_once()
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rospy/impl/", line 667, in receive_once
    p.read_messages(b, msg_queue, sock) 
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rospy/impl/", line 353, in read_messages
    self._read_ok_byte(b, sock)
  File "/opt/ros/hydro/lib/python2.7/dist-packages/rospy/impl/", line 336, in _read_ok_byte
    raise ServiceException("service [%s] responded with an error: %s"%(self.resolved_name, str))
rospy.service.ServiceException: service [/save_map] responded with an error:

can someone explain for me what this means? I have tried to use a service '/save_map' and that doesn't seem to work for me. (BUT i could swear I had /save_map working in the past.)

edit retag flag offensive reopen merge delete

Closed for the following reason question is not relevant or outdated by tfoote
close date 2018-01-30 17:43:15.752204


hey, did you solve this problem? i am having exactly the same error when running the python code Much appreciation for your help

wassimhariri gravatar image wassimhariri  ( 2016-11-23 08:34:08 -0500 )edit