Ask Your Question
0

Openni2 problem with registered depth points

asked 2014-05-09 06:14:04 -0500

abd_el_mon3em gravatar image

updated 2014-05-09 06:18:33 -0500

Hi,

I have an Xtion depth camera attached to nao robot, and I try to get registered depth points from it but the topic almost publishes nothing (except one or two messages after long time), also I receive the following warnings:

Image messages received:      5
CameraInfo messages received: 22
Synchronized pairs:           0

Image messages received:      4
CameraInfo messages received: 22
Synchronized pairs:           0

Note: I run openni2 on the robot just to load the driver and to publish tf, and I run other openni2 on remote PC to do the processing.

Note: I have tried to subscribe to raw rgb image (rostopic hz /topic_name ) and it works correctly alone, and to subscribe to depth raw image and also it works correctly alone, but when I subscribe to both of them in parallel only one of the works.

Can anyone help me, I am new to ros and openni2 and these stuff.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-08-13 05:33:57 -0500

isura gravatar image

Ubuntu 14.04 - ROS Indigo

This is because the depth_registration option is not selected.

Start rqt_reconfigure

rosrun rqt_reconfigure rqt_reconfigure

Select the driver from the left side and activate the depth_registration option.

You should now be able to see the registered rgbd pointcloud in rviz.

image description

image description

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-05-09 06:14:04 -0500

Seen: 1,049 times

Last updated: Aug 13 '14