Ask Your Question
0

robot_pose_ekf output to fake_localization

asked 2014-05-09 04:18:11 -0500

Hansg91 gravatar image

updated 2014-05-09 04:18:24 -0500

Hey,

I have robot_pose_ekf running and accepting wheel odometry and imu data and it is publishing on /robot_pose_ekf/odom just fine. I was wondering however what the idea of this output was, I was expecting nav_msgs/Odometry as output, because fake_localization takes this as input. Am I conceptually doing something wrong here?

Best regards, Hans

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2014-05-09 15:18:08 -0500

Tom Moore gravatar image

robot_pose_ekf produces a PoseWithCovarianceStamped message. This is due to the fact that robot_pose_ekf does not include linear or angular velocities in its state estimate; it only estimates the pose (x, y, z, roll, pitch, yaw) of the robot. You should change your callbacks to accept PoseWithCovarianceStamped messages.

If you need an Odometry message, though, I would encourage you to try the robot_localization package.

edit flag offensive delete link more

Comments

I also have a similar problem. In order to change the callback to accept PoseWithCovarianceStamped, should I basically change the type of base_pose_ground_truth in this file ?

ROSCMBOT gravatar imageROSCMBOT ( 2014-09-11 16:29:57 -0500 )edit

I'm afraid I'm not familiar with fake_localization. I'd ask this as a new question.

Tom Moore gravatar imageTom Moore ( 2014-09-11 21:51:26 -0500 )edit

Thanks Tom. I switched to robot_localization and it seems to be working with fake_localization too

ROSCMBOT gravatar imageROSCMBOT ( 2014-09-11 22:09:12 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-05-09 04:18:11 -0500

Seen: 101 times

Last updated: May 09 '14