Ask Your Question
0

control loop lose its desired rate

asked 2014-04-12 21:37:51 -0500

zsbhaha gravatar image

updated 2014-04-13 22:35:34 -0500

Procópio gravatar image

###Hi,every earnest fork## In the past of couples weeks, I have been tuning robot's navigation. But it still have some troubles when going to nav goals even with a static map.

One of those question is control loop always lose its desire rate. When I use my own notebook on the robot, I set control frequency = 8Hz, and it runs good, but when I use another computer, the warning always jump onto screen. I know the reason is either the latter computer sucked or some parameter was not properly set.

Here it is the key configuration about the latter computer

Intel Atom D2550 1.86GHz

2G RAM

and base_local_planner parameter

controller_frequency: 8
recovery_behavior_enabled: true
clearing_rotation_allowed: true

TrajectoryPlannerROS:
   max_vel_x: 0.55
   min_vel_x: 0.25
   max_vel_theta: 1.2
   min_vel_theta: -1.2
   min_in_place_vel_theta: 0.9
   escape_vel: -0.4
   acc_lim_x: 2.0
   acc_lim_y: 2.0
   acc_lim_theta: 2.5

   holonomic_robot: false
   yaw_goal_tolerance: 0.3 # about 18 degrees
   xy_goal_tolerance: 0.2  # 10 cm
   latch_xy_goal_tolerance: true
   pdist_scale: 0.8
   gdist_scale: 0.4
   meter_scoring: true

   heading_lookahead: 0.5
   heading_scoring: true
   heading_scoring_timestep: 0.8
   occdist_scale: 0.3
   oscillation_reset_dist: 0.1
   publish_cost_grid_pc: true
   prune_plan: true

   sim_time: 2.0
   sim_granularity: 0.04
   angular_sim_granularity: 0.025
   vx_samples: 18
   vtheta_samples: 30
   dwa: true
   simple_attractor: false
edit retag flag offensive close merge delete

1 Answer

Sort by » oldest newest most voted
0

answered 2014-04-13 22:39:41 -0500

Procópio gravatar image

Those messages are related to your computer not being able to complete all the calculations in the frequency you asked. So if you have those warnings in one machine but not in the other, that means the culprit is the lack of power on your computer. You can relax some of the parameters if you want to keep the 8hz frequency, specially the last block in your config file. For instance, try to reduce the sim_time, vx_samples and vtheta_samples and increase sim_granularity and angular_sim_granularity.

edit flag offensive delete link more

Comments

Thanks for your suggestion .

zsbhaha gravatar image zsbhaha  ( 2014-04-14 15:23:56 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-04-12 21:37:51 -0500

Seen: 406 times

Last updated: Apr 13 '14