unable to create an octomap from a .bag file using PointCloud2

asked 2014-04-12 15:03:37 -0600

rosAS gravatar image

Hello everyone,

I have a bag file which consists of "PointCloud2" with a corresponding "tf" messages. I am trying to build up an octomap using the inbuilt octomap_server in ROS.

Steps I followed:

  1. Launched "roscore" in one terminal
  2. Edited the file "/opt/ros/groovy/stacks/octomap_mapping/octomap_server/launch/octomap_mapping.launch" mapped the cloud_in to my PointCloud2 topic and changed the name of field to "base_link" as given in the header of the bag file.
  3. Launched octomap node: "roslaunch octomap_server octomap_mapping.launch" in a new terminal
  4. Played the bag file: "rosbag play <filename.bag>"

Now I am getting this error in the 3rd step-console.

Failed to find match for field 'x'. Failed to find match for field 'y'. Failed to find match for field 'z'.

  1. Now I tried to check if the octomap_server is actually publishing anything back or not: "rostopic echo octomap_point_cloud_centers " (for PointCloud2: and I am getting the output here)

  2. After this I tried to save the point cloud in form of a .ot file: "rosrun octomap_server octomap_saver <outputfile.ot>"

  3. But now when I am trying to visualize this octomap using "octovis" : "octovis out.ot"

"I am not able to see a octomap out of it."

I further looked into this and found this issue : dev.pointclouds.org/issues/821

edit retag flag offensive close merge delete

Comments

Can you share the bag file? Were you able to resolve the issue?

pallyra1 gravatar imagepallyra1 ( 2018-02-19 05:24:12 -0600 )edit