ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Error on Skeleton Markers

asked 2014-03-25 14:22:00 -0500

pinocchio gravatar image

updated 2014-03-26 09:26:01 -0500

I follow the instruction on Skeleton Markers h*ttp:// Sorry I do not have the right to publish a link, but that package is so cool.

However I encounter some problems (ROS Hydro + Ubuntu 12.10).

When I install it, on command git checkout hydro-devel, it says fatal: Not a git repository (or any parent up to mount point /home) Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set). I do not know what does it mean. But I can catkin_make the package...

After installation, I try to run it. however the first method does not work for me, while the second method works well.

UPDATE It works by following answers below. Thank you very much @Pi Robot. However there is a warning. I think it relates to the depth registration. You know, I cannot display registered RGB D image right now. As show in The log of catkin_make skeleton markers is listed below. The warning is in the last four lines.

rical@rical-CF-19RHRAX1M:~/ros_kinect$ catkin_make Base path: /home/rical/ros_kinect Source space: /home/rical/ros_kinect/src Build space: /home/rical/ros_kinect/build Devel space: /home/rical/ros_kinect/devel Install space: /home/rical/ros_kinect/install ####

Running command: "cmake /home/rical/ros_kinect/src -DCATKIN_DEVEL_PREFIX=/home/rical/ros_kinect/devel -DCMAKE_INSTALL_PREFIX=/home/rical/ros_kinect/install" in "/home/rical/ros_kinect/build"

#### -- Using CATKIN_DEVEL_PREFIX: /home/rical/ros_kinect/devel -- Using CMAKE_PREFIX_PATH: /opt/ros/hydro -- This workspace overlays: /opt/ros/hydro -- Using PYTHON_EXECUTABLE: /usr/bin/python -- Using Debian Python package layout -- Using CATKIN_ENABLE_TESTING: ON -- Call enable_testing() -- Using CATKIN_TEST_RESULTS_DIR: /home/rical/ros_kinect/build/test_results -- Found gtest sources under '/usr/src/gtest': gtests will be built -- catkin 0.5.81 -- BUILD_SHARED_LIBS is on -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -- ~~ traversing 1 packages in topological order: -- ~~ - skeleton_markers -- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ -- +++ processing catkin package: 'skeleton_markers' -- ==> add_subdirectory(skeleton_markers) -- Found GLUT: /usr/lib/i386-linux-gnu/
-- skeleton_markers: 1 messages, 0 services DEBUG variable catkin_INCLUDE_DIRS: /opt/ros/hydro/include;/usr/include DEBUG variable OpenNI_INCLUDE_DIRS: /usr/include/ni DEBUG variable GLUT_INCLUDE_DIRS: DEBUG variable orocos_kdl_INCLUDE_DIRS: /usr/include/eigen3;/opt/ros/hydro/include -- Configuring done -- Generating done -- Build files have been written to: /home/rical/ros_kinect/build ####

Running command: "make -j4 -l4" in "/home/rical/ros_kinect/build"

#### Scanning dependencies of target std_msgs_generate_messages_cpp Scanning dependencies of target std_msgs_generate_messages_py Scanning dependencies of target geometry_msgs_generate_messages_cpp Scanning dependencies of target geometry_msgs_generate_messages_py [ 0%] [ 0%] Built target geometry_msgs_generate_messages_py [ 0%] Built target std_msgs_generate_messages_cpp Built target geometry_msgs_generate_messages_cpp [ 0%] Built target std_msgs_generate_messages_py Scanning dependencies of target std_msgs_generate_messages_lisp Scanning dependencies of target geometry_msgs_generate_messages_lisp Scanning dependencies of target skeleton_tracker Scanning dependencies of target skeleton_markers_generate_messages_cpp [ 0%] [ 0%] Built target std_msgs_generate_messages_lisp Built target geometry_msgs_generate_messages_lisp [ 14%] Scanning dependencies of target skeleton_markers_generate_messages_lisp Generating C++ code from skeleton_markers/Skeleton.msg Scanning dependencies of target skeleton_markers_generate_messages_py [ 28%] [ 42%] Generating Lisp code from skeleton_markers/Skeleton.msg Generating Python from MSG skeleton_markers/Skeleton [ 57%] [ 57%] Built target skeleton_markers_generate_messages_lisp Generating Python msg for skeleton_markers [ 57%] Built target skeleton_markers_generate_messages_py [ 57%] Built target skeleton_markers_generate_messages_cpp Scanning dependencies of target skeleton_markers_generate_messages [ 57%] Built target skeleton_markers_generate_messages [ 71%] [ 85%] [100%] Building CXX object skeleton_markers/CMakeFiles/skeleton_tracker.dir/src/KinectDisplay.cpp.o Building ... (more)

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-03-25 16:06:22 -0500

Pi Robot gravatar image

Thanks for the bug report. I was missing a step in the installation instructions: you have to first 'cd skeleton_markers' before doing 'git checkout hydro-devel'. Here are the corrected instructions and I have also updated the ROS Wiki page:

$ cd ~/catkin_ws/src (change to match your catkin workspace directory)
$ git clone
$ cd skeleton_markers
$ git checkout hydro-devel
$ cd ~/catkin_ws
$ catkin_make


edit flag offensive delete link more


Hi @Pi Robot, Thanks for your help. However, using this new instruction makes skeleton_marker does not work. I mean when I use the old one, Method Two on instruction works, although error occurs on git checkout hydro-devel. When I add cd skeleton_markers and git checkout hydro-devel following the new instruction, error of git checkout hydro-devel disappears, but error appears on catkin_make. Because there is some limit, I revise my question and update the log there. Many thanks.

pinocchio gravatar image pinocchio  ( 2014-03-26 06:20:20 -0500 )edit

Hi @pinocchio, it looks like you have a problem in your beginner_tutorials package. Try moving that package out of your catkin_ws/src folder for now, then remove the devel, build and install subdirectories beneath catkin_ws so you are starting clean, then re-run catkin_make.

Pi Robot gravatar image Pi Robot  ( 2014-03-26 06:41:33 -0500 )edit

Hi @Pi Robot, I initiate a new workspace, and install skeleton_markers in it. However the same error occurs. The log is posted on the question. Thanks again for your help.

pinocchio gravatar image pinocchio  ( 2014-03-26 06:59:04 -0500 )edit

Looks like you might be missing the Glut libraries. Please try 'sudo apt-get install freeglut3 freeglut3-dev' and then re-run catkin_make.

Pi Robot gravatar image Pi Robot  ( 2014-03-26 07:48:21 -0500 )edit

Thank you very much @Pi Robot. It works now, except a warning shown. I think it is related to the depth_registration. You know I cannot enable it to show the registered RGBD image. I post the problem here.

pinocchio gravatar image pinocchio  ( 2014-03-26 09:25:17 -0500 )edit

Question Tools

1 follower


Asked: 2014-03-25 14:22:00 -0500

Seen: 538 times

Last updated: Mar 26 '14