Ask Your Question
0

Attempting to compile from source - error making libGLU for libstage

asked 2014-03-12 08:53:34 -0500

Alec Thompson gravatar image

I've been trying to build ROS Hydro from source on my laptop, running Ubuntu 13.10. However, I keep running into a compile error with openGL.

==> Processing plain cmake package: 'stage'
==> Building with env: '/home/alec/ros_catkin_ws/install_isolated/env.sh'
Makefile exists, skipping explicit cmake invocation...
==> make cmake_check_build_system in '/home/alec/ros_catkin_ws/build_isolated/stage/install'
==> make -j8 -l8 in '/home/alec/ros_catkin_ws/build_isolated/stage/install'
make[2]: *** No rule to make target `/usr/lib/x86_64-linux-gnu/libGLU.so', needed by `libstage/libstage.so.4.1.1'.  Stop.
make[1]: *** [libstage/CMakeFiles/stage.dir/all] Error 2
make: *** [all] Error 2
<== Failed to process package 'stage': 
  Command '/home/alec/ros_catkin_ws/install_isolated/env.sh make -j8 -l8' returned non-zero exit status 2

Reproduce this error by running:
==> cd /home/alec/ros_catkin_ws/build_isolated/stage && /home/alec/ros_catkin_ws/install_isolated/env.sh make -j8 -l8

Command failed, exiting.

Trying the commands given to reproduce the error gives the following output:

alec@Ares:~/ros_catkin_ws$ cd /home/alec/ros_catkin_ws/build_isolated/stage && sudo /home/alec/ros_catkin_ws/install_isolated/env.sh make -j8 -l8
make: *** No targets specified and no makefile found.  Stop.

I've looked up the issue in a more general scope, not focused on ROS, and most of the solutions involved adding a missing symlink (though the most recent posts about a failure to compile with libGLU.so are dealing with Ubuntu 11, so it's not exactly up-to-date), but checking the file locations themselves showed that the symlinks were all there. I also tried purging and reinstalling the openGL drivers, which resulted in the same error.

Thanks!

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2014-04-06 21:47:45 -0500

ffurrer gravatar image

I had the same problem once I installed the nvidia drivers on my notebook but there was actually a missing link. So for me the following resolved the compiling problem

sudo ln -s /usr/lib/libGL.so.1 /usr/lib/x86_64-linux-gnu/libGL.so

Hope that this works for you as well.

Cheers

edit flag offensive delete link more

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

Stats

Asked: 2014-03-12 08:53:34 -0500

Seen: 1,235 times

Last updated: Apr 06 '14