Ask Your Question
1

package collada_parser: dae.h not found

asked 2014-03-06 22:16:19 -0500

JanJaap gravatar image

Hello,

I'm trying to build ROS from source. The system I am using is:

Ubuntu 13.10

ROS groovy desktop-full

I used this guide to build the system: [I have no karma to post the link]

Ubuntu is a fresh install from disk. Compiling went well, except that the dependency on the libyaml parser was not solved, I installed those packages and it worked, however when trying to build the collada_parser packages, I get the following error:

kempenaarjj@ce011:~/ros/catkin_ws$ cd /home/kempenaarjj/ros/catkin_ws/build_isolated/collada_parser && 

/home/kempenaarjj/ros/catkin_ws/install_isolated/env.sh make -j2 -l2
[100%] Building CXX object CMakeFiles/collada_parser.dir/src/collada_parser.cpp.o
/home/kempenaarjj/ros/catkin_ws/src/robot_model/collada_parser/src/collada_parser.cpp:45:17: fatal error: dae.h: No such file or directory
 #include <dae.h>
                 ^
compilation terminated.
make[2]: *** [CMakeFiles/collada_parser.dir/src/collada_parser.cpp.o] Error 1
make[1]: *** [CMakeFiles/collada_parser.dir/all] Error 2
make: *** [all] Error 2

The collada packages I got installed on the system(either via the rosdep dependency command or by manually using apt-get:

kempenaarjj@ce011:~/ros/catkin_ws/build_isolated/collada_parser$ dpkg --get-selections | grep -v deinstall | grep coll
collada-dom-dev                 install
collada-dom2.4-dp               install
collada-dom2.4-dp-base              install
collada-dom2.4-dp-dev               install

Also a dae.h is present on the system:

kempenaarjj@ce011:/$ find -name dae.h
./usr/include/collada-dom2.4/dae.h

I already found that there were tickets regarding this in the bug tracker, however they do not state a fix. Which dependency do I need to install here in order to make this package work?

Regards, Jan Jaap

edit retag flag offensive close merge delete

Comments

I have a similar problem on OSX 10.8. dae.h is installed by homebrew in /usr/local/include/collada-dom2.4 [EDIT] never mind, it looks like I just add to re-run CMake for it to find the collada-dom-config.cmake

po1 gravatar imagepo1 ( 2014-04-28 03:48:58 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2016-04-26 08:36:04 -0500

Evgeniya gravatar image

My solution was to edit CMakeLists for that package and change the version from 2.3 to 2.4 and then it worked

edit flag offensive delete link more

Comments

It worked for me too. I edited the src/robot_model/collada_parser/CMakeLists.txt.

J. Santos gravatar imageJ. Santos ( 2017-03-03 20:06:54 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-06 22:16:19 -0500

Seen: 2,190 times

Last updated: Mar 06 '14