Ask Your Question
1

How can I use Qt 5 with ROS catkin?

asked 2014-03-05 06:32:11 -0600

Rr gravatar image

I'm able to use qt_ros, but it creates package depending on Qt4, but I need Qt 5.1 or older to use QSerialPort. How can I do it? Is it a bad idea?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2014-03-05 17:58:27 -0600

hamid gravatar image

please see this question and change

find_package(Qt4 COMPONENTS QtCore QtGui)

to

find_package(Qt5 COMPONENTS QtCore QtGui)
edit flag offensive delete link more

Comments

1

I tried, but it says "CMake Error at /home/roman/Qt/5.2.1/gcc/lib/cmake/Qt5/Qt5Config.cmake:3 (message): Qt5 requires at least CMake version 2.8.9 Call Stack (most recent call first): test/CMakeLists.txt:9 (find_package)". ROS Hydro Medusa uses CMake 2.8.3...

Rr gravatar imageRr ( 2014-03-05 20:08:00 -0600 )edit

This was not possible in Qt5.0 and you had to call find_package() seperately like: find_package(Qt5Widgets) find_package(Qt5Declarative) https://www.kdab.com/using-cmake-with...

OzzieTheHead gravatar imageOzzieTheHead ( 2016-02-02 11:37:20 -0600 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

1 follower

Stats

Asked: 2014-03-05 06:32:11 -0600

Seen: 5,098 times

Last updated: Mar 05 '14