Ask Your Question
0

turtlebot imu installation

asked 2014-03-03 21:22:20 -0500

chao gravatar image

updated 2014-03-03 21:22:35 -0500

Hi,

I am currently using turtlebot kobuki base with hydro on ubuntu 12.04. With reference to this question, would like to ask where can i edit the has_gyro parameter?

Another question, can I just use robot_pose_ekf to subcribe to my new imu data and do the gmapping using the odom_combined?

Thanks

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2014-03-05 16:24:42 -0500

bit-pirate gravatar image

Regarding your first question, Kobuki has a built-in gyro. The gryo is used to determine the robot's rotation, since it is much more reliable then using the wheels' encoder output difference.

If you like to disable the usage of the gyro for odometry, set the use_imu_heading to false in kobuki_node/param/base.yaml ( https://github.com/yujinrobot/kobuki/... ).

And regarding your second question, yes, you can use robot_pose_ekf to use the data from your extra gyro for gmapping. Just make sure your remap the topics accordingly.

edit flag offensive delete link more

Comments

noted, thanks for your answer

chao gravatar image chao  ( 2014-03-05 19:37:02 -0500 )edit

How would you do the same for a Create base?

Loneflyer gravatar image Loneflyer  ( 2015-10-19 05:48:27 -0500 )edit

The Create 1 did not have a gyro built in. So the TurtleBot kit was sold with an external gyro. With this set-up you would need to fuse the odometry data from the Create base with the gyro data using tools like robot_pose_ekf. Don't know what the new Create 2 comes with ...

bit-pirate gravatar image bit-pirate  ( 2015-12-08 02:22:37 -0500 )edit
0

answered 2014-03-04 04:27:53 -0500

ahendrix gravatar image

The Kobuki base should have the gyro built in, and it should be enabled by default in the launch files. I suspect they're already doing all of these things in the default launch files.

Is there a reason why you think the IMU is not enabled or the EKF is not running?

edit flag offensive delete link more

Comments

as i am currently trying to build a map of a library which is quite big (about 50 x 100m i estimate) with the similar shelves placed nicely across. however, i am not able to get a nice map using gmapping. so, i guess either i need to improve either my hokuyo laser (10m range) or install a better imu?

chao gravatar image chao  ( 2014-03-04 13:12:13 -0500 )edit

It may be worth trying hector_slam as an alternative. You can also spend some time tuning the gmapping parameters that control when to resample. As long as your laser reliably detects obstacles, you should be able to tune it to build a map.

ahendrix gravatar image ahendrix  ( 2014-03-04 13:20:41 -0500 )edit

i tried the hector_slam and it turned out not as good. am now using robot_pose_ekf to publish base_footprint, should make the odometry better. just found useful information here http://answers.ros.org/question/92131/imu-sensor/, should be helpful. thanks alot :)

chao gravatar image chao  ( 2014-03-05 02:32:24 -0500 )edit

Your Answer

Please start posting anonymously - your entry will be published after you log in or create a new account.

Add Answer

Question Tools

2 followers

Stats

Asked: 2014-03-03 21:22:20 -0500

Seen: 1,661 times

Last updated: Mar 05 '14