ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Binary Packages for ROS Hydro on ARMHF

asked 2014-03-03 16:47:52 -0500

daalt gravatar image

updated 2016-10-24 08:59:14 -0500

ngrennan gravatar image

I have ROS Hydro running on Ubuntu 12.04 (for armhf) on a Pandaboard ES. I'm having trouble running some of my nodes on this board because packages are missing. I have tried to install these packages individually using apt-get but I get an "unable to locate package" error.

Are the following binary packages available for armhf? How can I see what is available and what isn't?

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2014-03-03 17:44:17 -0500

ahendrix gravatar image

The ARM buildfarm status for Hydro is at:

I haven't tried to build moveit on ARM. If it builds from source easily, I can add it to the build farm and see how it does.

rviz doesn't build on ARM. The OpenGL support and the support libraries aren't there, and I wouldn't expect it to be fast enough even if I could get it to build. The error I'm seeing on the farm is:

-- checking for module 'OGRE'
--   found OGRE, version 1.7.4
-- OGRE_PLUGIN_PATH=/usr/lib/arm-linux-gnueabihf/OGRE-1.7.4
CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:91 (MESSAGE):
  Could NOT find OpenGL (missing: OPENGL_gl_LIBRARY)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:252 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/cmake-2.8/Modules/FindOpenGL.cmake:153 (FIND_PACKAGE_HANDLE_STANDARD_ARGS)
  CMakeLists.txt:31 (find_package)

robot_model isn't building on ARM because it depends on collada_urdf, which fails to build with the following error:

lboost_date_time-mt -lboost_system-mt -lboost_thread-mt -lpthread /opt/ros/hydro/lib/ /opt/ros/hydro/lib/ -lcollada-dom2.4-dp -lboost_program_options-mt -lassimp -Wl,-rpath,/opt/ros/hydro/lib:/tmp/buildd/ros-hydro-collada-urdf-1.10.18-1precise-20140221-2137/obj-arm-linux-gnueabihf/devel/lib: 
devel/lib/ undefined reference to `vtable for Assimp::IOSystem'
devel/lib/ undefined reference to `typeinfo for Assimp::IOSystem'
collect2: ld returned 1 exit status
make[4]: *** [devel/lib/collada_urdf/urdf_to_collada] Error 1
make[4]: Leaving directory `/tmp/buildd/ros-hydro-collada-urdf-1.10.18-1precise-20140221-2137/obj-arm-linux-gnueabihf'
make[3]: *** [CMakeFiles/urdf_to_collada.dir/all] Error 2
make[3]: Leaving directory `/tmp/buildd/ros-hydro-collada-urdf-1.10.18-1precise-20140221-2137/obj-arm-linux-gnueabihf'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/tmp/buildd/ros-hydro-collada-urdf-1.10.18-1precise-20140221-2137/obj-arm-linux-gnueabihf'
dh_auto_build: make -j1 returned exit code 2
make[1]: *** [override_dh_auto_build] Error 2
make[1]: Leaving directory `/tmp/buildd/ros-hydro-collada-urdf-1.10.18-1precise-20140221-2137'
make: *** [build] Error 2
edit flag offensive delete link more


Thanks for the excellent response! Looks like I need to find an Intel-based board for my application.

daalt gravatar image daalt  ( 2014-03-05 01:49:54 -0500 )edit

MoveIt and collada_urdf are potentially fixable. If you can verify that they work and/or provide patch files, I can incorporate them into the build process for the ARM build farm.

ahendrix gravatar image ahendrix  ( 2014-03-05 08:14:38 -0500 )edit

This question suggests that rviz can be built on ARM, but I haven't tested it myself or gotten feedback that it runs well enough to be useful:

ahendrix gravatar image ahendrix  ( 2014-03-05 08:16:16 -0500 )edit

Question Tools

1 follower


Asked: 2014-03-03 16:47:52 -0500

Seen: 419 times

Last updated: Mar 03 '14