ROS Resources: Documentation | Support | Discussion Forum | Index | Service Status | ros @ Robotics Stack Exchange
Ask Your Question

Unable to build ROS Foxy for arm32 architecture

asked 2020-08-05 10:46:07 -0500

atb033 gravatar image

Hi all,

Since arm32 is a Tier 3 supported architecture for ROS Foxy (REP 2000), I am trying to build it from source. I came across a whole bunch of build errors while doing this. Can someone please help me with this?

System setup

  • Operating system
    • Ubuntu 20.04
  • System Architecture
    • armvf

More info

I tried using the cross-compile tool, but it didn't work as there is no official armhf version of ros:foxy-ros-base docker image

Please let me know if anyone can help me out. Thanks in advance.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2020-08-06 01:57:41 -0500

lukicdarkoo gravatar image

Support for arm32 platforms has been downgraded in Foxy:

Here is one alternative:

We successfully managed to cross-compile Foxy base packages for Raspberry Pi Zero. You may need to change it a bit for your platform, but it should not be a big issue.

edit flag offensive delete link more

answered 2022-01-29 16:24:21 -0500

uxsapien gravatar image

Dockerfile for building a docker image with ros foxy (installed from source). Worked for me on a Raspberry Pi 4 running Ubuntu Server 32-bit. This would be compatible with armhf, armv7 architectures.

edit flag offensive delete link more

Question Tools



Asked: 2020-08-05 10:46:07 -0500

Seen: 618 times

Last updated: Aug 06 '20